Issues with Flatpak (install and/or update)

Hey there! I’ve decided to chime in after I couldn’t find any up-to-date or relevant issues covering this.

I’ve been noticing that, despite functionality being fine in the end, for every flatpak that I install (so, say com.usebottles.Bottles and it’s dependencies) it gives me the following warning:

Warning: Failed to get revokefs-fuse socket from system-helper: Remote peer disconnected

Not having found any up-to-date information, I decided to ask here if there’s been any known issues with this, and maybe get a fix too (if it even breaks anything, so far it doesn’t seem to)

Although, whilst this did happen to me on both my Laptop (ThinkPad T470s) with a fresh Fedora 39 install, it is primarily bothering me on a non-standard Fedora install, namely Ultramarine 39, on my Desktop.

I found this other post here on the site:

It references using this command to repair the issue:

sudo restorecon -v /usr/libexec/flatpak-system-helper

1 Like

If there is one selinux issue it seems wise to run the restorecon command for the entire system.
sudo restorecon -vR /and let it run until the activity ends before doing a shutdown or reboot.

1 Like

I have tried this before to no avail, I should’ve mentioned that in the original post.

I’ll try this, thanks!
EDIT: To no avail, this didn’t solve the issue :frowning:

1 Like

Have you tried flatpak -y repair ?

Yeap, no changes.

Did you shutdown?

Not yet, I didn’t realise that was required

I’ll report after a reboot :upside_down_face:

UPDATE: No change :confused:

Hello. I have the same problem and can’t find a solution. Can somebody help me? Thank you.