Is it possible to turn off System Network Notifications?

This is driving me kinda nuts now. I think it’s due to using a VPN (wireguard via network manager) but either way, I have to stop these notifications. They pop up continuously, very distracting and annoying.

Is there any way to disable these please?

Screenshot from 2024-06-23 17-50-09

Settings | Preferences | Look and Feel |Pop Up Notifications
There is a check box for Enable Do Not Disturb
This would likely stop all notifications but at least would stop the one bothering you.
I also found this solution that may be better suited for you:
Use dconf Editor and change this setting-
org.gnome.nm-applet disable-connected-notifications

1 Like

Or you could toggle the “Do Not Disturb” switch directly from the Notifications menu:

EDIT: that would, however, disable all notifications, not just the ones regarding VPN.

2 Likes

Interesting

3 Likes

Looks like no solutions then, shame, but thanks

Thanks. I’d rather not disable all, but may just try it for lack of alternatives.
Regarding the ‘dconf Editor’, above my paygrade I’m afraid, no idea what you’re suggesting but sounds like it was referred to on the linked threads in the most recent post above, and probably won’t work on F40 anyway. Thanks for posting.

Added workstation