IoT - how to disable zezere?

Built a pi4 with Fedora 39 IoT but it seems zezere-ignition NEVER works, as there’s a LONG known issue with an “altroot” being set as / (which isn’t very “alt” now is it…?). So ok well I’ll just disable zezere-ignotion as it doesn’t seem to do ANYTHING useful yet (Really, only ssh keys?!)

But I can’t disable it, I can’t delete the binaries from the RO filesystem of course, and whilst I presume I can eliminate it, this all feels like the wrong way to be going. How do I best stop zezere-ignition starting EVERY MINUTE and spiking my CPU and clogging up my system? It seem mad that this is an issue at all…

You should be able to disable the timer that kicks off the service:

# systemctl disable zezere_ignition.timer --now

There’s an open issue about how often the service runs upstream - `zezere_ignition` spamming the journal with audit messages · Issue #137 · fedora-iot/zezere · GitHub

That’s what I’d have thought but it doesn’t work, keeps coming back.

I removed zezere-ignition from the base image and rebooted. And it wouldn’t boot. And I swore a lot. Eventually I worked out I can restore the previous image by changing the order of the /boot/loader/ files to get back in. After that though I realised I can delete the /boot/ignition.firstboot and everything “works” then.

Seems like a big that’s impossible to justify, some real quality control issues I’ve seen with fedora 39 in various incarnations so far.

I tested this on a F39 IoT x86_64 VM and it worked for me.

Maybe the behavior is architecture dependent, but that would be quite surprising.

There’s a recent issue around symlinks in /etc that was reported - Writing symlinks under /etc/systemd/system in Fedora IoT 39 apparently doesn't survive the reboot. · Issue #14 · fedora-iot/iot-distro · GitHub

Could be related to the problems disabling the timer.

Hi, I think my topic is also related, I recently opened a discussion here:

I also filed a bug:

https://bugzilla.redhat.com/show_bug.cgi?id=2259451

I have in common that

  • systemctl enable is not persistent across reboot
  • I cannot reproduce the issue in Gnome Boxes in Fedora 39 IoT x86_64
  • As in the GitHub Issue I used arm-image-installer to install Fedora 39 IoT on RPI4B