Installing WordPress Locally

Good morning everyone,

I want to start out by stating that I am new to Fedora, so bear with me :rofl:. I work doing web design and a myriad of other things at my job. Previously, I used Bitnami with Wordpress on my Windows 10 machine to mess around with some ideas on my local machine, at home. I haven’t used any form of Linux for about 10 years and recently tried to install Bitnami on Fedora, but it is not supported.

Long story short, is there method for doing this in Fedora? I just want to have the ability to use my localhost and WordPress to mess around with some ideas for the websites prior to going into work and doing the actual creation, or potentially just creating my own website.

Thank you in advance for any information/help!

Hello Travis, and welcome to our community!

You have a few options here:

  1. Install directly on Fedora: How to install WordPress on Fedora - Fedora Magazine. This one is the most straightforward, but isn’t a direct alternative to Bitnami.

  2. Try out Sandstorm! While I don’t use it as much any more (see below), it is a great tool, and probably the closest thing to a direct alternative to Bitnami.

  3. Podman! Depending on what you want exactly and your background technical prowess, this may not be right for you. However, I thought I’d mention it anyway as I love containers so much, and they generally make tasks like the one you are trying to do trivial. Find out more here if you are at all interested: Docker


Thanks a ton Andrew!

I will definitely look all of this up tonight and go with whatever one works best. I will post an update once I get everything figured out!

1 Like

I think I am going to install Sandstorm a little later tonight.

However, I am very interested in this container stuff. Are containers like Software as a Service (SaaS) where I can use a certain piece of software without having to download it locally on my system? I instead would use a container from a separate server that contains the software that I am intending to use. Once I quit using it there are no remnants of it on my device other than whatever I have saved which can be called upon when I utilize the container again? Or are my thoughts on containers completely wrong lol?

I have tried to install Sandsorm, but I get this error:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 100 77576 100 77576 0 0 326k 0 --:–:-- --:–:-- --:–:-- 326k
environment: line 1: _declare: unbound variable

Please install curl(1). Sandstorm uses it to download updates.

I used curl --version to verify that it was installed and it shows the following:

curl 7.76.1 (x86_64-redhat-linux-gnu) libcurl/7.76.1 OpenSSL/1.1.1k-fips zlib
/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.1 (+libidn2/2.3.0) libssh/0.9.
5/openssl/zlib nghttp2/1.43.0
Release-Date: 2021-04-14
Protocols: dict file ftp ftps gopher gophers http https imap imaps ldap ldaps
mqtt pop3 pop3s rtsp scp sftp smb smbs smtp smtps telnet tftp
Features: alt-svc AsynchDNS brotli GSS-API HTTP2 HTTPS-proxy IDN IPv6 Kerbero
s Largefile libz Metalink NTLM NTLM_WB PSL SPNEGO SSL TLS-SRP UnixSockets

Weird. Can you try:

sudo bash

You are somewhat right and kind of wrong. I encourage you to research podman and docker. Guides for both are pretty much interchangeable, but podman is generally preferred on Fedora systems.


Below is what I receive from wget

–2021-05-02 20:46:32--
Resolving (… 185.199.10
8.133,,, …
Connecting to (|185.199.1
08.133|:443… connected.
HTTP request sent, awaiting response… 404 Not Found
2021-05-02 20:46:32 ERROR 404: Not Found.

1 Like

+1 for Podman! :grinning_face_with_smiling_eyes:

Whoops my bad.


curl | sudo bash