Installing Veracrypt?


Does anyone know how to install Veracrypt on Fedora 31 / 64bit?

I tried rpm 30 and manual install, but no success.

Kind Regards


This is not enough to go on. Could you expand on what you did and how the system reacted, perhaps error messages?

EDIT: I use tcplay for my truecrypt volumes. It’s command line, but it does the job.

veracrypt is available on rpmsphere. Personally, for sensitive programs like encryption, I prefer to stick to official repos or manually compile from source: VeraCrypt - Free Open source disk encryption with strong security for the Paranoid

Both options should work. What problems did you encounter?

If I remember correctly, the manual install just partially installed the app. Clicking the icon did nothing after the installation. The RPM one gave error message something like ‘…missing file’.

I am GUI person. : )

How can you use official repo? How do I add the repo? I had already downloaded the file from the same website, and tried installing it. I had two files. Double clicking the icon after the installation did nothing.

The RPM one gave error message something like ‘…missing file’.

The graphical user interface is fine if everything is ok. Error messages that are fundamental to the applications technical functioning usually appear on terminal. Technically they appear on stderr or stdout. Especially error messages concerning startup. Get used to using a terminal to start a program if things start to happen that from the gui you do not understand. It just might show stuff you miss when running the gui only.

Normally, I always use a terminal for install and in case of problems, because it shows what is wrong. Those messages are invaluable for troubleshooting.

In your case an incomplete install is sufficient indication that failure is in the making. My advice is to uninstall and use the standard Fedora repo. Installing from a website is not normally a good idea, unless you know exactly what you are doing.

The only truecrypt compatible software in the fedora libraries is tcplay. I found that by running dnf search truecrypt and dnf search veracrypt:

If you really want to install from the website, be prepared to solve technical problems if their install is not compatible with the fedora environment. Again, prefer the standard libraries. And use command line for both install and first execution. Once you know it runs, you can run gui in case of a graphical program.

In case of tcplay you are dealing with a command line program for which no gui exists. Read their docs.

hope this helps.

EDIT: study dnf to understand how to install. The command man dnf should tell you what you need to know. tldr:

dnf install <packagename>                        to install
dnf remove <packagename>                         to remove
dnf search <query string>                        to search for a name like truecrypt
dnf repoquery <searchoptions> <filename>         to search

Read the manual page for more info (man dnf).

None of these packages are the :fedora: 31 repository

So, Please don’t install any additional repo, just download from the veracrypt website, the Centos 8 version packaged, it works really well, regurally CentOS pakaged works in :fedora:

CentOS 8:

and install it via:

sudo dnf install veracrypt-1.24-Update3-CentOS-8-x86_64.rpm

Easy isnt’ it


1 Like

I was referring to tcplay, a truecrypt compatible package. I found it by looking for truecrypt and veracrypt, that both are not in Fedora, tcplay is.

I use tcplay on fedora and veracrypt on ms-windows. But it is your choice: either use tcplay from the fedora repo or download veracrypt from the website and use a centos package and trust it keeps working on fedora.

1 Like

Or use the generic linux installer for veracrypt or compile it from source.

1 Like

Thank you hhlp. It worked! Now I can encrypt sensitive data. One interesting thing was that after [sudo dnf install…] terminal seemed to be downloading extra to install. I thought it was a complete package.

Hi gbonnema,

Thank you for a detailed explanation and [man dnf] command. I’ve also found the webpage and bookmarked it. I have used CentoOS 8 one to install Veracrypt. I really wish I could write more in this reply.

Another interesting thing is that I thought you have to use [sudo -Uvh…] or something like that to install .rpm package. :grinning:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.