Veracrypt from a toolbox

Hello,

I want to keep my underlying OS as clean as possible so I am trying to run veracrypt and possibly Virtualbox in a toolbox. I was able to run veracrypt and Virtualbox in Fedora 30 Workstation.

I installed veracypt rpm in the toolbox. When I tried to mount an existing veracrypt file, I get a permission denied /media/veracrypt1. Since I cannot write to the /media directory, I added new directory to my /Documents folder. I tried to mount the veracrypt file to this new directory and I get the “Failed to setup a loop device”.

Someone recommend typing in modprobe loop but modprobe does not exist in toolbox.

TIA.

Jeff

Hi @scoobyscrappy,

This is an older solution but still works for people on Fedora. I would try it out and if you still get an error some people in the Arch Linux wiki recommended doing a system reboot that fixed the issue.

Hi miker256,

Thanks for your reply.
I tried out the commands in the post and it did create a /dev/loop0 file but when I tried to mount the veracrypt file I still get the “Failed to setup a loop device”.
I decided to install veracrypt as a LayerPackage in the CoreOS and it works.

Jeff