Silverblue: Adding Veracrypt volume returns error "Failed to set up a loop device"

  1. On Fedora Silverblue 38 host I created new container:

    distrobox create --name veracrypt
    distrobox enter veracrypt
  2. Inside container, I downloaded and installed Veracrypt program:

    sudo mkdir -p /opt/veracrypt
    sudo chown $USER:$USER /opt/veracrypt
    wget  --directory-prefix=/opt/veracrypt/
    sudo dnf --assumeyes install /opt/veracrypt/veracrypt-*
  3. From inside of container I lauch Veracrypt GUI:

  4. Then I created new encrypted file container. Container is successfully created.

  5. Click on Select File button to mount a volume and selected encrypted file. I think problem already happened, no error returned, but on volume list I see no path to file (my file: $HOME/Download/veracryt_file).

  6. Click on Mount button to mount disk and after entering password I get error: “Failed to set up a loop device: /var/home/user/Downloads/veracrypt_volume.”

Any help is appreciated.

By the way, I don’t want to install Veracrypt into rpm-ostree or similar. Flatpak does not exists.

Sounds like a Distrobox error to me. Possibly contact their community for help.

I have retested the same version of Veracrypt on Ubuntu 23.04 and I see after step 6 above when I enter encrypted volume password, new dialog is opened to ask for “admin” password. I type in password, this is the password for user with sudo/root privileges and then volume mounts.

I see in Fedora Siverblue “admin” dialog to enter sudo password does NOT open at all, but instead error is returned, like described in step 6.

Inside container I tried to start program with: sudo veracrypt but I have got the same error like in step 6.

You can not manage disks and mount points from an unprivileged container (toolbox, distrobox, etc.) so you’ll likely have to overlay that package.

1 Like

Like @siosm suggested I installed Verycrypt using layers.

# Download Veracrypt Fedora package into user's Downloads directory from
# Currently this is link bellow (for later references check above URL)
wget --directory-prefix $HOME/Downloads

# Install downloaded RPM package
rpm-ostree install $HOME/Downloads/veracrypt-1.25.9-CentOS-8-x86_64.rpm

# Rebooted to make affect
systemctl reboot

# Start Veracrypt program

Tasks from GUI:

  • Create new volume and mount it.
  • Volume password dialog opens, type in volume password.
  • Administrator dialog opens, type in sudo user password.
  • Volume is successfully mounted.
  • Open Files program change directory to /media/veracrypt and create new file.
  • After you would like to dismount go to Veracrypt GUI and click on Dismount button.

I did some tests and it looks Veracrypt works fine. Thanks for help.