Installed system Won't Boot to USB


Been using Ubuntu for years so know my way about Linux fairly well. Tried the Live KDesktop spin and very impressed. Decided to install to a USB before I fiddle with my main system hard drive partitions.

Installation went fine, no errors except whenever I tell the bios to boot to the named USB disk it goes to GRUB on my mains system. Tried it three times thinking I may have missed something but same result.

Viewing the drive on gparted it shows the main partition as lvm2pv - was expecting it to be Ext4 so am a wee bit baffled.

It is nothing to do with safe boot as I have that disabled.

Any pointers appreciated.


You are probably better off testing Fedora by putting a live-image into the USB stick (and not by installing to the disk). I mean, that’s essentially one reason we have Live media – live testing without messing with the drive.

So grab a Live image and use that to make a boot-able USB using tools like Rufus or Fedora Media Writer. You have plenty of options … check out this page
Go have fun!.


To add to this: if you go for Rufus, make sure you use dd mode. ISO mode tends to break stuff quite a bit!

Yes, initially did that, worked so well I wanted to try out a system that retains settings, hence trying installation.

My current PC already has 4 partitions so I’d have quite a bit of fiddling to install Fedora to my main drive, the reason I wanted to try and install on a USB stick.


I’ll check Rufus out, I used dd to copy ISO to USB.


Shows how long since I’ve fiddled with partitions, seems with LVM that one can have more than 4 primary partitions :sunglasses:


Beautiful phrase, that one.

Ah … limited by partitioning scheme :face_with_monocle:. How about an external USB Drive (the proper spin-disk ones made by WD, Samsung, Seagate etc… not the sticks)? That should give you ample testing freedom! Otherwise, if you want persistence with Live media, the tools I suggested give you those options (NOTE: I have experienced failure trying persistence with Rufus … so you might want to avoid that). If you do it right you’ll get a live-media (USB) that allows you to install things, save, play around … and reboot. Everything stays as you left them (the magic of persistence).

Eh … did you read that :sunglasses: page I shared earlier? Seriously, you should consider that page.

The limit of 4 primary partitions is for MBR partitioning only. For modern drives (required if they’re over some limit, maybe 2TB), using GPT partitioning would put the limit at 32 primary partitions. And if you ran LVM on top of the whole drive instead, you probably don’t have a (unreasonable) limit at all.


I only see reference to grub once in this thread may I ask if you installed grub to the main drive of system or to the USB drive ?

1 Like

it is the System … actually @geffers has a solution already here

Was that the one on creating and using Live Image? If so yes, read up on that. Went for the installation on my main HD in the end. Initial boot problems but resolved with help from this forum.

Now got Fedora, Ubuntu and Windoz options, seldom boot the latter, just to do updates really.

Thanks for all the suggestions folks, got a friend trying out Fedora now too. The word is spreading.


I’m never quite sure where GRUB ends up, the menu follows the layout in /etc/default/grub in the Fedora system so guessing it is on that partition. Never quite got my head round grub2.

Assuming the boot sector in the main HD is somehow pointing to my Fedora partition.


So my current drive has a couple of Windoz NTFS partitions, an ext4 which Ubuntu resides on and now Fedora has a small ext4 partition and a big LVM one. Baffled how it all works seamlessly together but it does. UNTIL IT DON’T :cowboy_hat_face:


I’m not certain if this is helpful, but I also boot my fedora install from an external USB3 port via an SSD sata to USB3 cable. I installed grub to the external so that the install could be portable to other systems. Works perfectly by changing the boot drive thru system board versus operating system. So it’s not the usual dual boot config but works none the less.