I have a bug related to suspend/idle mode of my laptop. How do I properly gather enough information for a bug?

Hello, I have a laptop HUAWEI MateBook D16 which has Fedora 38 Workstation with latest updates. Overall it works great, I only have annoying bugs when my laptop left idle or put to suspend.
If I put into suspend and try to wake it up, I have some buggy login screen shown to me where I can’t put in a password, and have to force reboot it.
So I decided that I can live without suspend and disabled it completely. I set power button behaviour - Nothing. After I open the lid, it seems like it works, but buggy again - I can’t launch anything: if I launch firefox, it says it’s already open, but it isn’t. Tried to launch task manager - it didn’t show up either. Tried to reboot - lots of errors printed, some of them saying ‘unable to launch reboot binary’ or something like that.
I realize that the info I provided here is not enough to submit a proper bug, so I ask help how to gather the relevant information, so I could submit it and it could be fixed. Especially related to suspend, because the laptop is effectively unresponsive. Thank you.

Hello @aleksandrosprey ,
Welcome to :fedora: !
When it occurs, you could type in a terminal, journalctl -b -1 --priority=3 to get the errors from the last boot. (this assumes you had to force reboot with the power button). Knowing those errors would be a good place to start. As well you could post them here inside “< error listing copied from terminal />” or use the code block button in the menu above.

Every time I open the lid the behaviour is different. Now I saw terminal window with some errors. Had to force reboot it.
Here is the output. I closed the lid on 10 of July around 20:00, today is 11’th

it’s too big to paste here

июл 10 20:08:45 fedora gdm-password][80998]: gkr-pam: the password for the login keyring was invalid.
июл 10 20:08:51 fedora gdm-password][81018]: gkr-pam: the password for the login keyring was invalid.
июл 10 20:08:54 fedora gdm-password][81057]: gkr-pam: the password for the login keyring was invalid.
июл 10 20:08:57 fedora gdm-password][81069]: gkr-pam: the password for the login keyring was invalid.

The password that was entered is invalid it appears.

I don’t think it’s relevant to the laptop being unresponsive after idle/suspend.

Do you updated also all your bios updates?

You know what, I just did.
Did not seem to resolve the issue tho.
Here are my errors. I suspended the laptop, woke it up. It seemed like working, but nothing could be launched. I tried to reboot, here are the errors I saw.
journalctl -b -1 --priority=3

journalctl -b -1 --priority=4 > fedora3.log

From what I see, the issues waking up from suspend and from long idle are exactly the same. So it’s not really about suspend itself.

Hey, a inxi -Fzx wold really help to see more about your hardware.

What i see in the Log is that the wifi not works.

Have you tried to boot other kernel versions?

Do you have a option to use RJ45 (cable) to connect to the network?

I also recorded another variant of how my laptop may ‘wake up’ after idle (no suspend).

I did not try other kernels explicitly, but this bug persists with me since october, so it’s safe to assume it’s present with other kernels.
I don’t have an Rj45 port. Now will try with wifi disabled.

1 Like

I enabled airplane mode and it didn’t seem to affect anything. Both variants - unresponsive login screen and being unable to launch any executable seem to appear.

Would probably be a good investment to look for a dongle so that you are able to use it.

You need access to your system, to update drivers while the kernel changes. Otherwise you will lock you out by default.

I see quite often pop up troubles with this MateBooks.

I suppose not. Is yours a 12th gen I7? I know there was some discussion around here regarding Fedora’s use of the various sleep modes available on more recent CPU models, don’t know if this is applicable to your issue(s).

it’s 12th gen i5.
Besides wake up issues, there is also overheating issue when in idle. It’s way hotter than under any load.
I feel like leaving fedora and linux, because these issues are just annoying.

So I decided to give linux one last shot with RHEL distro. And it seems like I do not have any issues I had with fedora. Everything just works, kinda like on windows.

I found that PowerProfiles daemon was causing me all kinds of power management issue. I disabled it and installed tuned and haven’t looked back. But this is not a laptop.