I can not access one specific web site

Oddly enough, that web site is Fedora Forum. Linux or Windows. Makes no difference. I multi boot this laptop and the same holds true for the other Linux distributions installed on this machine. Firefox thinks about it for a minute or so and then times out.

I’ve rebooted the modem and have cleared the DNS cache. At least I think I cleared the DNS cache.

The connection has timed out
An error occurred during a connection to www.forums.fedoraforum.org.
The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Something is blocking this site. Any thoughts?

Note that I just installed Chromium. No love there either.
Installed Brave browser. Same result.

I did connect to fedoraforum, no problem here . You did not blacklist the site?
Try connect without add-ons with a clean Firefox.

I did not blacklist the site. I’ve disabled all Firefox extensions and restarted the browser. Still no go.

I can connect to Fedora Forum with my phone so the trouble is with my computer or in home network.

Just found that if I turn my phone’s wifi on I can not access the site with that device either.

Does it also fail on the command line or the command below returns what seems to be a bunch of valid HTML?

$ curl https://www.forums.fedoraforum.org

If it also fails, try this command to see if the domain name is being resolved correctly:

$ dig www.forums.fedoraforum.org

You could compare the results with the results from some external DNS lookup tool.

If the resolved IP address is correct, try checking the route and see if it stops somewhere unexpected:

$ sudo traceroute -Tn -p 443 www.forums.fedoraforum.org

If none of these fail but you still can’t connect using Firefox, hit F12 in Firefox to open the Developer Tools; go to the Network tab in the developer tools; use the little cog at the right side and enable Persist Logs; also use the trash bin on the left to clear previous entries, if any; then browse to the website and see if there’s any failed requests in the Network tab. This could give you some clues, in case there are failed requests other than the main one.

1 Like

May this forum can help you?