Certain websites are not opening in fedora

I have dual booted fedora kde spin with my windows 11, and I am a beginner in linux. Certain websites like ‘aniwave.to’ which I use to watch anime works perfectly in my windows 11 but it doesn’t open in fedora in any browser, even I ping this website using terminal and it returned 100% packet loss with message ‘ping dotblocking.dummy’, I even went to a proxy website to use this site but even the proxy site crashes when i typed aniwave.to. Can someone help me why this site is working in windows 11 but not in fedora 39 kde spin?

Check the output:

nmcli connection show
resolvectl --no-pager status
resolvectl --no-pager query aniwave.to
nslookup aniwave.to
nslookup aniwave.to
curl -L -v -o /dev/null https://aniwave.to/

This was the output, and yes I am also not able to login in fedora forum through my fedora linux whenever I try to login it says 504 bad gateway. I can login if I refresh many times and continue the form submission. And, still I am not able to access aniwave website through my fedora kde spin.
I have tried many times to switch to linux but these types of problem always irritates me so I go back to windows 11. But, this time I want to solve all these problems that arises in linux.

Edit your wireless connection settings and specify a custom public DNS provider:
Public recursive name server - Wikipedia

1 Like

I have applied these settings, but it didn’t worked (and I have also tried this before) but after restarting the computer, it worked.

Thank you so much for your help, now I understood why it was not working.
Once again thank you so much. :smile: