Huge cursor within certain applications (F39, Silverblue)

I’m using Fedora Silverblue to run a number of the devices in my house. One of them is a System76 Meerkat (12th Gen i3) that I’m using as an HTPC for my living room TV.

It works great, but I have an issue that exists only on this device: when it’s within certain applications, the mouse cursor becomes absolutely enormous. So far I’ve only spotted this happening within gnome-terminal and within Firefox. But it doesn’t happen on the desktop, or within Files, Software, Spotify, Steam, or any of the other applications that I have installed on this device. The installation is up to date as of this post, and I haven’t themed or modified the it in any way aside from layering the steam-devices package from RPMFusion (which I have also done on other devices not experiencing this issue).

Of note, because it’s attached to a 4K TV, I do have the scaling set to 300% so that I can easily see text from my couch. The cursor appears normal most of the time despite this, but it’s comically huge within Firefox and Terminal windows, as if it’s being scaled up an additional 300% in some instances. I also have Brave installed, and it doesn’t happen within that. One more detail that I should note is that I’m using the Firefox flatpak from Flathub, and I’ve manually enabled Wayland support for it using Flatseal. But this issue does still happen with the Firefox package installed in the base image, and I haven’t touched that in any way. This was also happening in F38.

I’m struggling to narrow this down. It may be a Fedora issue, or a Gnome issue, or any number of other things. But I figure this is a good place to start. Let me know if I can provide any more relevant information.

That sounds like a GTK3 bug. I found a similar report, but it should be fixed already.

Does it also happen at 200%?

That sure narrowed it down real quick! It sure looks like this is it.

  • It does not happen at 200% scaling. Switching back to 300% scaling brings the issue back.

  • After your mention of GTK3, I opened the System Monitor and sure enough, it’s happening within that window, too.

I can reproduce it here. Also, the cursor is blurry in GTK4 apps. The only place it looks correct is GNOME Shell.

The bug is back because the fix was reverted: