HP Printer and PDFs: "Print job was not accepted"

I have a HP 9010 series printer that works fine under Windows with HP Smart, so I know things are fine on that end. Under Fedora 39, skanlite was able to scan a document, so I think the Linux drivers are fine as well. However, when I go to print that document with okular, the job just stays in the print queue with the status “Print job was not accepted.”

Some Googling suggests that this may be an okular problem: 452339 – Okular uses pdf title to create print job. If the title is too long the printer refuses the job

However, the same thing happens with lpr from the command line and from Firefox, so I thought it might be in how the pdf was generated. But the same thing happens with the Gnome Document Scanner, and the most old-school thing I could think of, xsane and lpr. So there is something wrong with the setup. I just let the system choose the setup, but the driver it chose, “Current - HP OfficeJet Pro 9010 series, Fax, driverless, 2.0.0” looks like the only sensible one in the list. So I’m out of ideas, and I couldn’t find another post that had the same error message. How do I get printing to function on Fedora?

This may sound silly, but, have you power-cycled the printer? I have an HP OfficeJet 9010 as well, but on Ubuntu 23.10 currently, and ran into a similar issue - scanning was working fine, but printing just stayed in the queue forever. Rebooting my PC didn’t work, but turning the printer all the way off and then back on worked in my case.

Odd that I didn’t think of that, maybe because it’s a wireless LAN printer. Good idea to check, but unfortunately power cycleing doesn’t seem to change anything. I’ve rebooted Linux as well, since I had to switch over to Windows to make copies for my son before working on this further.

That looks like the fax config not the actual printer config. Is that correct?
Do you have only one config for that printer or are there 2 configs, one for fax and one for printing.

The MFP HP printers I deal with mostly offer config for both fax and for printing and the functions are different. The fax config does not print but is designed to send the document as a fax.

Hmm. I guess I just assumed the “Fax” driver had the full functionality of the non-fax driver, plus additional functionality for printers with fax capability. Maybe that’s totally wrong. I will try switching the driver. Unless I plug a phone line into it, it doesn’t even matter.

When I first started using the HP MFP printers I found that hplip wanted to configure both the fax and the printer separately. When I allowed it to set up the fax I seemed to have some problems since I never connected a phone line. After that I told it to not configure the fax and the occasional problems disappeared.

Aaaaand it was indeed totally wrong. You must be right and the fax driver is just fax, because now it prints fine and also reports the ink status on the printer settings page. I guess Linux modularizes it because there are, or were, standalone fax drivers? I guess I was deceived by the scanner working, I guess because there is very little difference between receiving a fax and scanning.

So Fedora missed the right driver by a hair and and the luser didn’t know enough to recognize what was right in front of him in the driver menu. Fortunately it was a very easy fix, thanks to both of you for setting me straight on that. If the printing works I suspect everything will work.

When using hplip for the HP printers the scanner cannot be used without also adding in the HP plugin for the scanner. I hope the scanner continues to work for you. I use hplip and never have a problem with my HP Color Laserjet printer.

Jeff V: yeah, looks like that was it. I don’t have a phone line connected either, so unless I run a line I will never need the fax driver.

Plugin? Hmm. Maybe something changed? I’ve had a lot of HP printers in the $distant_past and don’t recall needing that. Or I got lucky a few times. Where do I get and install the plugin if that’s necessary?

<google, google, …>

OK, maybe you’re talking about this? It suggests, by omission, that the OfficeJets don’t need that plugin like the LaserJets do, if I follow. I never owned a LaserJet, so there’s no reason I’d have encountered it.

ETA: forgot the link. Here it is:

That is it.
I have never been able to use the scanner on my Laserjet without installing the plugin.

I do use hplip, and the printer is initially configured with hp-setup on the cli or with the hplip-gui that also can be installed as a separate package. During initial setup it asks if the user wishes to install the plugin. If the printer is already configured and hplip is updated to a newer version then the plugin must also be updated to the same version – done with hp-plugin on the cli or with the gui.

Since I do not use an OfficeJet I also do not know about the plugin, but hplip does seem to indicate it is required for all MFP devices.

bro idk why sometimes i get that same problem, my printer is a samsung

jeff im also having a problem with my samsung laserjet scan , i instaled the gnome scan , but most of the time it didnt recognize the scan of the mfp printer that is connected through usb. Im on fedora SB how i manage to install the printer driver (i downloaded the tar file of the driver from samsung)?

You are trying to install a driver for a samsung printer on silverblue?

That has nothing to do with the subject of this post. Please open your own thread on that issue

i entered on this subject because my printer many times show that same message “Print job was not accepted” when printing through lan network from android. but then see you guys talking about plugin/driver and you said about scan problem without installing the plugin. im also facing scan problem on my samsung printer, hence the question. So im wondering if i may have to install some plugin from samsung to fix these issues that im also having, i found the driver but dont know how i approach since im using fedora sb

Ah. Well, I installed hplip and ran ‘sudo hp-setup’, and get “error: No device selected/specified or that supports this functionality.” At first I thought it just couldn’t find the printer, then I realized it probably means “I only found printers that don’t need the plugin.” So I did some digging, and this appears to explain why the PPD file says it is “driverless”: CUPSDriverlessPrinting - Debian Wiki

So I think hplip was telling me that I don’t need hplip, because it uses a standard protocol CUPS already understands. If so, that’s a big improvement over the last time I installed a printer on Linux.

So it appears I still have a problem. Turns out that only monochrome printing works. I set it to default to color in the system settings, and also from the print dialog, and it doesn’t matter that it is set to color. I finally printed a test page from system settings and that comes out monochrome too.

That’s very puzzling and right now I have no ideas. I rebooted and verified that it prints color on Windows, and my Google Fu isn’t apparently strong enough, so I’m not sure what to look at next.

OK, I got it. I resorted to the advanced engineering method of “pressing all the buttons and flipping all the switches,” and It turns out you can create multiple printer entries that point at the same physical printer. So I made a second printer entry, and it offered me a choice of “drivers.” (In fact they were PPD files, not drivers, unless there is a driver named “driverless.” Seems unlikely.) The two “driverless” ones I’d seen before, and a couple of new ones that didn’t say driverless. So I tried one of them, and behold, it printed in color, but couldn’t read the ink levels. However, the last one seems to manage both, and also printed in color from Okular, so I think I have a fully functioning printer in Linux.

I hope this helps the next guy with a similar problem. The most important lesson: never underestimate the power of Brute Force And Ignorance. :smiley:

ETA: you might wonder why I didn’t just change the PPD on the existing printer. I tried, and it offered me the option, but it didn’t seem to actually change. I don’t know why that didn’t work when a way to do it is provided. Took me a while to figure that out and start again.

A couple things you might want to consider.
I install Hplip-gui and install my hp printer via that app. It works well for me.
And where it’s a wireless printer you should set a IP address outside the normal DHCP range. If you don’t do that the printer IP address may change with every boot up or if you add anything else to the network. I set my IP address in the 200 range. so on mine it look similar to this (note this will be different for you if your router addressing is different) If your model has a tools screen to wifi setting and you should be able to set the Ip address then when you install the printer using Hplip-gui you can manually set the Ip and it should all work for you. Good luck.

Did you check for your specific model in the list of “driverless” IPP compatible printers (linked in the Debian article you referenced)? The Debian article mentions that printers which support Airprint should work with IPP (until Apple changes Airprint!). The main site for IPP is OpenPrinting.

Quoting OpenPrinting’s “Brief History”

… PPD files do not really fit in the picture anymore, and they also had their shortcomings, especially being rather unflexible in the possible types of user-settable options. Also, the need to drop filters and PPDs into reserved directories of CUPS makes it difficult to provide CUPS and printer drivers in sandboxed packages, like Snaps.