Lpr printing issue on FC36

I am running FC36 using XFCE.

I have an “HP OfficeJet Pro 9010 Series” (9015e in fact) printer which worked perfectly fine in FC35. In particular, I could print from the command line using ‘lpr’ or from, say, a web page using the printer dialog that popped up. The PRINTER env vrbl is set to “HP9015e”. All worked just fine in FC35.

When I updated from FC35 to FC36, I lost the ability to use ‘lpr’. Also, for a web page (say) I cannot use the default print dialog, but instead have to expand ‘More Settings’ and select “Print Using System Dialog”. From this point on, I get the proper options for my printer and everything prints perfectly fine.

If I run ‘lpstat -l’ immediately after boot-up/login, it returns no information.

If I run ‘lpr xyz.txt’, the return code is ‘0’ (echo $?) but no job is ever printed. At this point ‘lpstat’ shows the job is queued and ‘lpstat -l’ shows the job is queued with Status “Processing page 1”. No job ever gets printed. I can in fact cancel the job by running ‘cancel ’ and confirm it via another ‘lpstat’ command.

As a final piece of information, when I run ‘hplip’ (HP’s Device Mgr), it shows my printer with the correct full name (it must have retrieved it from the printer, right?), but it’s status says “Device Communication Error” with a Description of “Please correct the problem and try again”.

But I do not know what the problem is!

I have been reluctant to uninstall and reinstall the printer for fear that it will stop working entirely (ie, the ‘System Dialog’ will stop working with it).

Any suggestions on how I might debug this?
Why would a "Device Communication Error’ occur if in fact the printer works fine using the System Dialog?

Any help appreciated

  • Rich

How is the printer configured & connected. Wireless, ethernet, USB?
According to the user manual it may be connected in any of those ways.
I will base the rest on the assumption that it is network connected.

With all the HP printers I have used I first use the system printer setup tool and remove any automatically configured HP printer.
I configure the printer for network connection with a fixed IP which can be gotten either by setting it at the printer or by using a reserved address with DHCP from the router.
I then use hplip-gui and configure the printer, making sure to name the printer and to install the plugin so the scanner is functional. If not using hplip and the plugin the scanner is not functional on HP MFP printers.
I then do a test page and if that works then there is no problem with printing.
At that point I can use lpr to send print jobs to the printer using the name I gave it when it was set up.

I never need to use the system dialog since hplip gui is a management tool that allows control of all features on the printer. I also can use http://localhost:631 to manage all attached printers if I choose.

Hplip sets up the HP driver for the printer, and the autoconfig with avahi sets it up as driverless.

On my system lpstat -l returns nothing, but lpstat -p shows the printer and its status.

I just did a print of a file with $ lpr -P HP_Color_LaserJet FILE and both a text file and a pdf file printed properly.

Jeff -

Tx for taking the time to reply.
My printer is in fact networked (wifi) with a statically assigned IP.

Interesting, lpstat -p for me in fact yields:
printer HP9015e is idle. enabled since…

So I have no idea why ‘lpr’ will not print for me.
The job gets queued, but never, ever prints (as it did under FC35).

I guess I should suck it up and uninstall the printer and re-install it as you suggest. I wish I understood what was wrong…


Maybe the printer is stopped so the job is queued but does not print, waiting for the printer to be enabled again. I have occasionally had that happen in the past.

That is most interesting!
I don’t think I tried:

  1. Run an lpr job. It will fail to print

  2. Run a print job using the system print dialog, which will print

  3. Check if the now-awake printer prints the queued lpr job

I’ll try that out next time I log into my Linux PC. Tho, I have to believe I’ve had queued jobs in the past prior to a successful print. But maybe not…


  • rich
    (from Pixel5)

Since I use hplip, when my printer refused to print I used the hplip tool to check the status and found it stopped with jobs in the queue. I then started the printer and it printed all that was waiting in the queue.

Was not an issue of waking it up, but rather enabling a stopped printer.

Turns out it is NOT the printer stopping.
I have found an error message from the HP Device Manager:

Unable to open device hp:/net/HP_OfficeJet_Pro_9010_series?ip=

(The IP is valid. I can access the printer’s internal web admin page using that IP address. There is nothing in the admin process that indicates anything is wrong.)

No idea why this is so since I can in fact Print fine using the System Print Dialog. The printer itself is working fine (eg, i can send print jobs from my cell phone to it, the system print dialog works on my linux PC). It’s just ‘lpr’ fails to work from the command-line (tho a job is queued). It must be a Linux level issue. Dbus? this is now beyond my understanding of the low-level communication details.