Howto enable WIFI?


I’m nearing panic here. I’ve been unable to enable WIFI since Friday’s (Nov 26) updates. The problem occurred on both of my Dell laptops running Fedora 35, KDE version within hours. I don’t recall if it was after I rebooted after updates, but I think it was.
I reinstalled F35 on the Inspiron successfully and found WIFI was available like usual. But I was NOT successful on the Dell Precision (so I re-installed F35 there - rinse, repeat, no joy). The icon in the task bar only tells me that the WIFI is disconnected. I clicked the “enable wifi” button to no effect.
So I started again from scratch and again, no wifi.
The root question is “How do I enable WIFI on F35?”
Thanks for any help or info.

Hello @josephb ,
Hold on, don’t panic. Using nmcli find out what it sees with nmcli connection show to see if it has a connection, then nmcli d show to see devices NetworkManager controls.


Also check the output for hardware specific diagnostics:

lspci -n -n -k; lsusb -v -v -t; rfkill list all; nmcli radio all

Wow. Not 100% sure what to look for, BUT…
after entering those commands in a non-root terminal session, nmcli connections show gave me a blank line in return.
nmcli d show returned several lines, but the one of relevance read “Gen-state 20 (unavailable)”

lspci -n -n -k did show “qualcom Atheros/network wireless adapter” But I was REALLY not sure what to look for here. However, under network controller Qualcomm Atheros it read “kernel driver in use: ath9k”

lsusb -v -v -t returned nothing that I understood to be relevant. Please let me know if there’s something I can look for specifically here.

lastly, rfkill list all returned “wireless lan… Hardblocked: yes”
And that seemed very relevant. If that’s the case, please tell me how to unblock it so I can sleep tonight! :wink:
Thanks again


man rfkill

unblock id|type […]
Enable the corresponding device. If the device is hard-blocked, for example via a hardware switch, it will remain unavailable though it is now soft-unblocked.

is wifi in Bios ON ?
if it is an laptop it maybe has a wifi on/off key ?

1 Like

Not sure what you mean here, Sixpack. How do I find the correct id and type to issue that unblock command, please? I’ll try looking at $man rfkill to see if there’s more information for that command.
The laptop has nothing like a physical wifi on/off key, of course. But I WAS wondering if laptop’s wifi (or perhaps an internal antenna?) had gone bad. I sort of rejected that theory because both my machines had that problem at nearly the exact same time. Only one of them got wifi back when I re-installed Fedora 35. Identical hardware problems on both is unlikely. And the fact that one works now tells me the router probably isn’t the problem either.
Hum… I’m obviously going in circles trying to think through this, but I’m at a loss.

1 Like

Well, the corresponding fundamental answer, when you put it that way, is: on most hardware, it just is automatically detected and just works.

So I don’t think that’s really the right question here. Assuming the hardware has Linux support from the standard, recent Linux kernel (and it worked before, right?), something is wrong.

So the core problem isn’t “what to enable?” but rather “how can I find out what’s not working can correct that”.

So that basically means that NetworkManager does not have a connection established at all.
nmcl1 d show will show you all of the devices NetworkManager is aware of on your system. As an example I have both wired and wireless on my desktop system, and I only use wired so this is the output from my use of the command …

GENERAL.DEVICE:                         enp4s0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         F0:2F:74:B0:32:22
GENERAL.MTU:                            9000
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     enp4s0
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/1
IP4.ROUTE[1]:                           dst =, nh =, mt = 100
IP4.ROUTE[2]:                           dst =, nh =, mt = 100
IP6.ADDRESS[1]:                         fe80::f22f:74ff:feb0:3222/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 1024

GENERAL.DEVICE:                         wlp3s0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         B0:A4:60:33:14:AE
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     TP-Link_6E40
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/2
IP4.ROUTE[1]:                           dst =, nh =, mt = 600
IP4.ROUTE[2]:                           dst =, nh =, mt = 600
IP6.ADDRESS[1]:                         fe80::89c3:3f0c:b7c6:bef1/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 1024

GENERAL.DEVICE:                         p2p-dev-wlp3s0
GENERAL.TYPE:                           wifi-p2p
GENERAL.HWADDR:                         (unknown)
GENERAL.MTU:                            0
GENERAL.STATE:                          30 (disconnected)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         ::1/128
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = ::1/128, nh = ::, mt = 256

As you can see, my wireless is shown as actually connected at this moment since I set it up for this discussion, yesterday I was only connecting via wired lan. If you have a response of GENERAL.STATE as 20(unavailable) I am uncertain what may be causing it but possibly just look in your BIOS at boot to ensure that for whatever reason the wireless didn’t get disabled.

Matthew, you’re right.
I’m getting some slightly different information from the laptop this morning (and last night’s rum-and-coke may have had something to do with that).
Today, the rfkill list all command returned:
phy0: Wireless LAN
soft block: no
hard block: yes

dell-wifi: Wireless LAN
soft block: no
hard block: yes

I went through rfkill’s man file, and found the the way to enable it (rfkill enable {id|type} ), but see that the id|type format is “deprecated”. I tried every combination of phy0 Wireless LAN and dell-wifi: Wireless LAN I could think of but they all returned syntax errors. However, rfkill enable all was not rejected. But it also did nothing from my non-privledged session or from root either.


1 Like

Stephen, I’ll look at the nmcl1 d show command results again.
This morning I DID go through the BIOS at boot. I was surprised to see nothing at all pertaining to the wifi device or type. Real surprised. I’ll be looking at it again.

I feel like I’m making progress, though. So thanks to you (and Matt) for the help.

1 Like

Try cold boot, then re-enable Wi-Fi from Windows if you have dual boot.
If the issue persists, try downgrading the related packages:

sudo dnf downgrade \*-firmware

Be sure to select the previous kernel version while booting.

Vlad, good thoughts. Sadly, I don’t have dual-boot (I took Windows completely off this machine years ago!). I’ll try the dnf downgrade command and report back. Thanks for the suggestion.


I just tried the dnf downgrade cmd. from the root (privileged) account, Vlad. Didn’t work. The error message comes back saying “error during downloading metadata for repository ‘fedora’: …”

Of course. It needs to be on-line to do that. Double sigh.

Oh - forgot to mention, because I reinstalled from the original F35 iso, it’s using the 5.14 kernel (not the latest). The problem (on both my laptops) occurred with the 5.15 kernel we had last week.

I got with rfkill list all:

0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no

so the ID is “0” for BT and “1” for wifi.

and to block/unblock -AFAIK- you need to have “sudo” in front of the rfkill command:

sudo rfkill block 1
sudo rfkill unblock 1

should read
nmcli d show

You got my hopes up there for a minute, Sixpack. I tried the rfkill unblock command (with the number show in the results for rfkill list all that corresponds to the wireless lan). I then rebooted. It’s still disabled, though.

I’d be certain that this was a real hardware problem, except for 1 fact - the same thing happened on my other laptop at about the same time. Fortunately, that one came back after I re-installed and has been working since. That made it seem more like a software problem.

I do wish I could show you guys the output from rfkill and nmcli, but without access to the internet, I can’t get the file off the machine easily. I may spend some time trying to write the output to an SD, so I can transfer it to the working laptop that I’m using to communicate here. All I have to do is find that SD…

So you can do nmcli d show and it shows devices correct? With nmcli, you can start stop bring up etc iface’s.
So if your interface is named wifi as it is in my case, enter nmcli wifi up to bring it up. Please check into the nmcli command since NetworkManager is how to control your networking including wifi and bluetooth on Fedora Linux. man nmcli. Another good tool to check out for use with NetworkManager is nmstatectl, which provides even easier ways to configure networking on Fedora Linux.

Sorry for the frustrations here, Stephen. But I’m not successful with much here.
From the top, you sent me the results of your nmcli d show the other day. And there, you’ll see that your device name is wlp3s0, device type, wifi. Mine is wlp6so, type wifi.
So I used both the name and the type in the nmcli command with the up switch. Both return the message that the argument (wifi or wlp6s0) is not understood from both my non-privedged account and the root account.
I tried the same with nmcli network connenction up [wifi|wlp6s0] and nmcli radio up, also with no effect.
BTW, nmcli general status says STATE disconnected, WIFI disabled and WIFI-HW enabled.

This may be a totally different problem.
Please first reboot the wifi router.
Then provide the output of inxi -Nxx. You may need to install inxi before it can be used. Paste that output within code tags ( the </> on the toolbar above) so it maintains formatting as seen on the screen.
Then also post the output of ip a in code tags as well.

These 2 commands are so we can see exactly what device you have, the drivers in use, and the configuration that is currently active.

1 Like