How to start VNC server for running session (wayland)?

I normally start vncserver to have separate GUI session on remote machine, that’s from tigervnc. I know I used to be able to also vnc to existing session by doing x11vnc -usepw -display :1, but it looks like it doesn’t work anymore with wayland. I saw wayvnc, but I’m not sure if this is meant to be vnc server or running gnome session (it talks about wlroots which I don’t know what are they).
So how to get running wayland session enabled to be remotely accessed?

1 Like

AFAIK tigervnc doesn’t support wayland. I was looking into this today because of a powerdevil bug with X11 I encountered while using tigervnc. I had to switch my session to gnomex11 to get around it. wayland isn’t supported. Some good reference material is in this tutorial, but short answer is it’s not ready for prime time.

1 Like

wayvnc is for wlroots-based compositors (e.g. Sway), not for GNOME or KDE. Have you tried checking for sharing in the GNOME preferences?

1 Like

If you need to connect remotely to another computer running wayland instead of X11, you could use:
waypipe ssh -YC -l username machinename
or use Connections or Remmina with rdp protocol if you absolutely need the whole desktop (but why??). Remember first to allow the remote connection.

So if I enable desktop sharing in gnome preferences it will use RDP protocol on 3389 port like windoze?

Sometimes I want to connect to comp in another room to check status of a running application

More details here:

The status of any process could be seen from ssh, using ps aux, top, cockpit inside a web browser, whatever you prefer in order to see if it is running.
If you have, say, 4k resolution, you will saturate 1Gbit ethernet watching windows moving as molasses.

Yes, gnome-remote-desktop actually supports both RDP and VNC.
RDP can be configured in GNOME Settings and VNC using CLI:

# VNC server
sudo dnf -y install gnome-remote-desktop
grdctl vnc enable
grdctl vnc disable-view-only
grdctl vnc set-auth-method password
grdctl vnc set-password "${VNC_PASSWD::8}"
systemctl --user enable gnome-remote-desktop.service
systemctl --user restart gnome-remote-desktop.service
sudo firewall-cmd --permanent --add-service=vnc-server
sudo firewall-cmd --reload

# RDP/VNC client
sudo dnf -y install gnome-connections