How to permanently disable the touchscreen on wayland (F37)?

Hello there!

I’m in the process of updating my father’s laptop: A Samsung Ativ Book Series 5 (NP540U3C-A01VE) and, of course, installin F37 is part of the plan.

However, this laptop has some serious issue regarding the touchscreen: Some sort of ghost touch, as if someone was constantly touching the creen.

This, of course, made the computer almost unusable untill I found the way to permanently disable the touchscreen on Windows 10.

Since, there’s no way to disale the touchscreen in hardware, I need to get familiar with the process on Linux, F37 to be precise. I tried following this tutorial on Youtube, but is based on X11 and the issue is still present after the process on F37.

So, how do I permanently disable the touchscreen on a wayland-based system like F37?

Thanks in advance

A couple of possible options (untested since I have no touchscreen.)

  1. Use X instead of wayland. This is very easy since it can be selected by using the gear icon at the lower right of the login screen. Once selected and the user logs in with ‘gnome on xorg’ it remains running xorg unless the user selects otherwise when logging in.

  2. Disable the driver for the touchscreen so it never gets loaded. A file in /etc/modprobe.d/ can be created for that purpose once you know which driver module is being loaded for the touchscreen. Other blacklist files already there provide a template for what the content should be.

The command inxi -Fzxx should return info about the touchscreen and the driver it uses so you can work from that point. If inxi does not give you the driver info then lspci -nn should do so.

Update: I installed Fedora 38 on my father’s laptop and I applied this solution I found out there (A subReddit from another forum)

It worked… until I updated the system for the first time.

Since X11 will inevitably fade out of any Fedora version, using X is not on the table. So I really need a permanent Wayland solution.

Any thoughts?

Thanks in advance

Hello @jcas0058 ,
Did you follow the link it noted about the detailed version here Blacklisting a single USB device from Linux – Project Gus
Also available in the Fedora repo is USBGuard, a utility for managing USB device UDEV rules and access control. See this link 4.12. Using USBGuard Red Hat Enterprise Linux 7 | Red Hat Customer Portal. Please don’t pay too much attention to the fact it is from a RH POV, it will work on Fedora and is part of the Fedora Repo.


I tried both

The first one is the one that worked at the beggining, droped out after update.
The second threw me a hard reply: Permission Denied.

However: I tried #1 againtexto en negrita, this time reading carefully the commandline on the rule I was creating. Rebooted and is currently working. Hope it stays that way.

Thanks, @jakfrost