How to install the driver for wifi chip rtl8852BE?

I did a few search for the driver, and I found this repo: GitHub - lwfinger/rtw89: Driver for Realtek 8852AE, an 802.11ax device
I did the following steps as the instruction says:

For Fedora: You can install them with the following command

sudo dnf install kernel-headers kernel-devel
sudo dnf group install “C Development Tools and Libraries”
git clone GitHub - lwfinger/rtw89: Driver for Realtek 8852AE, an 802.11ax device
cd rtw89
sudo make install

but at the “make” command I got this error:
[vu_@fedora ~]$ cd rtw89/
[vu_@fedora rtw89]$ make
make -C /lib/modules/6.0.7-301.fc37.x86_64/build M=/home/vu_/rtw89 modules
make[1]: *** /lib/modules/6.0.7-301.fc37.x86_64/build: No such file or directory. Stop.
make: *** [Makefile:86: all] Error 2

I also did a few search but still not figure out how to fix this :<

sudo dnf --refresh upgrade
sudo reboot

thank you, I ran that command and now it works, but somehow there is still no wifi icon in my laptop, is there any chance you can help me with this, lol

Make sure to disable Secure Boot in BIOS/EFI and then build the modules with DKMS:

sudo dnf install git dkms kernel-devel openssl
sudo git clone \
sudo sed -e "/^MAKE/d;/^CLEAN/d
/^DEST_MODULE_LOCATION/s|/updates/|/extra|" \
/usr/src/rtw89-git/debian/rtw89-dkms.dkms \
| sudo tee /usr/src/rtw89-git/dkms.conf > /dev/null
sudo dkms add rtw89/git
sudo systemctl restart dkms.service
sudo tee /etc/modules-load.d/rtw89.conf << EOF > /dev/null
sudo systemctl restart systemd-modules-load.service

Hi, sorry for the delay, I just woke up an hour ago, after a “sudo dnf upgrade --refresh” (using ethernet) and a reboot the wifi somehow worked just fine, thank you for the help though