Realtek rtw89 no wifi

My wifi card is in a lenovo ideapad 5 aba7:
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device b852

I compiled the driver, following the instructions here (GitHub - lwfinger/rtw89: Driver for Realtek 8852AE, an 802.11ax device), but wifi is not working:
inxi -N
Device-1: Realtek driver: N/A
Device-2: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc

I have the following warning when compiling, everything seemed to have worked but no driver (wifi worked with lubuntu and with manjaro,but I wanted to use fedora i3 spin):
warning: the compiler differs from the one used to build the kernel
The kernel was built by: gcc (GCC) 12.2.1 20220819 (Red Hat 12.2.1-2)
You are using: gcc (GCC) 12.2.1 20221121 (Red Hat 12.2.1-4)

sudo make install:

Install rtw89 SUCCESS

$ lsmod | grep rtw
rtw_8852be 16384 0
rtw_8852b 356352 1 rtw_8852be
rtw89pci 81920 1 rtw_8852be
rtw89core 548864 2 rtw89pci,rtw_8852b
mac80211 1282048 3 ath9k_htc,rtw89pci,rtw89core
cfg80211 1097728 6 ath9k_htc,ath9k_common,ath,rtw89core,mac80211,rtw_8852b

Don’t know what to do.
Thank you!

Thank you Vladislav.
I already knew your code, and I have used now. The problem solved itself after
sudo yum update
I’ve been more than 20 years with debian, and -my fault- I forgot to update the system
Thank you again

1 Like