How to enable intel rapid start technology?

I see that Intel Rapid Start can speed up the computer’s resuming from hibernation. I use the following steps now:

  1. Automatically load the Intel_rst module at startup.
  2. Create an Intel FFS partition with a size of 17 G (this step is done under Windows. And this partition is different from the disk where Linux is located)

But when my computer goes to sleep, it doesn’t go into hibernation.

How can I do it?

My Laptop is Dell G15 5511, it should support intel rapid start technology.

The chipset in the laptop you mentioned is a HM570. It does not have Rapid Start Technology support. The last Chipsets to support IRST were the 9 Series chipsets of the Broadwell Generation CPUs (5th Generation Core i3/i5/i7) which were released in 2014.

1 Like

IRST is an old technology, no longer relevant since SSDs got cheaper - it helped if you had a system HDD and some little SSD (back then it was mostly 16 or 32 GB). Not sure if linux benefited from it, since it could hibernate to a different disk anyway.
Hibernation has it’s own downsides Reddit: Fedora does not support Hibernation, and it’s on purpose and is apparently a good thing!
You can try to enable it IF you really want to Hibernation in Fedora Workstation - Fedora Magazine

1 Like

s0 hibernate doesn’t seem to be available on linux. And s3 sleep consumes too much power for me (4% power consumption for half an hour). I’m using s4 hibernate now. But it recovers slowly.
I use macos at work and its sleep is very power efficient and resumes very fast. It is a pity that this technology cannot be used under linux.

What you mean by that? S0 is active.

Power consumption and available modes depend on hardware and it’s support. For macos it’s super easy since they design both software and hardware. In most other cases soft has to workaround some issues caused by hardware manufacturers.

It depends on disk speed, amount of used ram and kernel settings.

8% per hour is quite high, check out UEFI settings (sleep, WoL, always on USB ports, crap like Intel Smart Connect etc.) and look through dmesg and journalctl, maybe something needs tweaking. Start new topic, anyway.