Help needed: F35 Freezes when connected to wifi

Hey guys, newbie here.

I have recently updated my machine from F33 to F35. Everything works fine, but I noticed that when connected to wifi, the laptop freezes and I have to reboot the system. The specs are as follows:

HP laptop 14-cf0xxx
Processor: Intel Core i5-8250U CPU @1.6GHz x 8
OS type: 64-bit
GNOME Version: 41.2

uname -r (kernel version):

I also have Realtek rtl8821ce wireless card and installed tomaspihno driver (on F33 system). Any help would be greatly appreciated.

Welcome to the community @ivevdm

Did you try to uninstall the driver and perform again the steps you followed for F33 in order to install the driver?
(Realtek chips are nasty beasts with Linux).

Maybe these other posts can be helpful? Search results for 'rtl8821ce order:latest' - Fedora Discussion

In addition I’ve noticed that some Realtek modules can’t be compiled on kernel 5.15 due to the removal of some header files, but I don’t know if this is valid also for rtl8821ce ones.

I seem to recall earlier posts about the rtl8821ce chipset and updates to the chipset that are not supported by the distributed driver. If you can post the output of lspci -nn it will provide the actual chipset id which can be used to locate the proper driver. Mine, which is an atheros chipset, give this 04:00.0 Network controller [0280]: Qualcomm Atheros AR93xx Wireless Network Adapter [168c:0030] (rev 01) and the chipset ID is the part within the square braces. 168c:0030.
Yours will be similar for the rtl8821ce chipset.

Once you have the full chipset ID then a search for the driver will help.

Hello @ivevdm,
Welcome to
If your networking worked prior to upgrade, it should still work, and seems to. I would be more inclined to believe it is related to power management changes made to Fedora Linux in the F35 release that may be playing a more significant role here.
For instance, does the freeze happen immediately or after the power management kicks in from lack of activity say or lid closure?

Hey @jakfrost ,
It did indeed worked prior to upgrade, I saw some people complaining about this issue with similar specs. Currently, the laptop freezes after 10-15 mins of network connection (regardless of idle or active usage). It is the issue persistent with kernel version >5.1, so perhaps your suggestion is correct.

Hi @alciregi
Yeah, I did uninstalled the driver, installed it again, but this seem not to yield any results.
I was thinking about replacing realtek with something more linux-friendly but was not able to find any that would work with my motherboard (HP are nasty about upgrades and replacements).

Thanks for your suggestions, will look into them!

1 Like

@computersavvy here’s the output. Looking for the driver.

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]

This is one of the links found by searching for 10ec:c821 driver fedora

That guide is less than a year old and related to fedora 34 so it should be valid for fedora 35 as well.

i am using F35 and i am using usb wifi adapter without installing any drivers on it… but there is no problem on my F35…even i connect and disconnect my wifi adapter on running F35 sometimes but it will works perfectly without any reboot or hanging…