Wifi connects and disconnects after a few minutes

Hi! I’m new to fedora and I’m running on a issue that I dont even know how to start solving. I have a thinkpad e490 with the wifi adapter from realtek RTL8822BE. I’ve tried fresh installing it again but when I lspci on the terminal it shows:

05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac Wifi adapter (rev ff)

Wifi connects and disconnects after a few minutes. If i plug the internet cable I’m able to connect, the problem really seems to be with the wifi card. Here is the output for lspci -nn

and for inxi -Nxx

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000
           bus-ID: 04:00.0 chip-ID: 10ec:8168

Please show us the output of lspci -nn for that device. Also the output of inxi -Nxx

You did not actually tell us the problem, only the device you think it is related to.

What is happening? or not happening that you think should?
Describing in detail the problem will give us a starting point to possibly assist.

1 Like

edited the post with your request!

I think I run into a solution here the problem is that when I try to make what it’s said it shows me that there is an issue with a missing file named Error: Unable to find a match: linux-headers-5.14.10-300.fc35.x86_64 build-essential

I’ve found some other useful info from fedora problem reporting

What are you trying to build with make?
The error is straight forward. The kernel-headers package must be installed to build that package (whatever it is). If building things against the kernel you should also have the kernel-devel package installed.

You are a little (LOT) out of date with that kernel. The current kernel for fedora 35 is 5.15.13 and failing to update fedora before attempting to build anything is certain to cause problems in the future.

It is also quite possible that simply doing a sudo dnf update may get the proper driver installed for that chipset. Inxi did not display it but lspci did so it seems the driver is not installed.

I suggest you do an update, then reboot, then repeat the inxi -Nxx command to see if the device is now configured.
Another way to see what is happening with a device is by using dmesg and journalctl -b -e --priority 3 to see what errors are being logged with the current boot and looking for entries related to the device of interest…

updated the kernel… problem was not solved :confused: it stays connected for a while and disconnects again

the output for both lspci -nn and inxi -Nxx remain the same as before

the output is

the output


All that indicates the driver is not loading, although it would be much better if you were to copy/paste the text into your post using the </> Preformatted text button above so it could all be parsed and not just what is visible on a single screenshot.

Searching for the driver for that device ( ID 1Dec:b822, or possibly 10ec:b822 ) (it is hard to read the screenshot whereas text would be easy to read) I find this for the ID 10ec:b822 chipset

which indicates 2 possible drivers. rtw-8822be or rtw88-8822be and also references the rtw88 and lwfinger drivers.

I cannot verify the device 100% since you posted a screenshot, so please run lspci -vv and post (as preformatted text) the entire portion related to device 05:00.0 (the realtek wifi adapter). Also post the entire output of lshw -class network -numeric and inxi -Nzxx There is an additional part of the chipset ID I have not seen yet that will help identify that chipset within the database linked above.

I also found this as a tutorial on how to install the rtl8822be driver.


Hi @hdcpereira , Did you solve this connection issue in Fedora 35? I believe I’m having the same problem as you. I used Fedora 35 KDE. Everything was working fine until last week or so. I updated the computer (as usual) and my internet became very unstable. It stays connected but no internet, disconnecting or connecting all the time. I figured it would be some bug related to KDE and decided to switch to Fedora 35 Gnome, but the problem continued in Gnome as well. I’m thinking this bug is related to some wireless card driver or something related to the kernel, maybe.
The most curious thing about this is that before installing the Gnome version of the F35 I used the internet for a while through the live-usb itself and in this version (Fedora-Workstation-Live-x86_64-35-1.2.iso) the internet worked perfectly. The problem appeared after installing and subsequently updating the system. This further reinforces the idea that some recently updated package is causing these wireless problems. I’ll try to wait a while if an update appears that solves this problem and makes my internet work again as before. If that doesn’t happen, unfortunately I’ll have to install Debian or another version where this isn’t happening :cry:

I’m putting the print of the output of the commands

lspci -nn

Notice in the upper right corner the question mark on the Wireless symbol showing that the internet is not good.

The ping command showing instability (internet dropping and coming back all the time)

inxi -Nxx

inxi -b for more details

Does anyone have an idea how to solve this problem?

Hey @thiagotabosa see this discussion which might be same problem as you: Latest Fedora 35 kernel update 5.16.15-201 breaks ath9k Wifi - Ask Fedora. I updated today to latest kernel and it has fixed my issues with same brand network adapter as you.

1 Like

Please read this.