Help installing Microsoft fonts like Arial, Times New Roman

I have tried to find a question similar to this, but couldn’t so i’m sorry if this question was already asked. I need to use Arial and Times New Roman fonts in LibreOffice but i cant install them for some reason. i followed instructions on many websites but they didn’t work or they were outdated. Other than that as a new user of Fedora im very pleased. Thanks for your help :slightly_smiling_face:.

sudo dnf install mscore-fonts-all

@ledeni I tried the command but the fonts are still not showing up on LibreOffice Writer. I also checked on the fonts app and they are not there.

@scottytrees I dont think it is working, it installed Times New Roman but not Arial only Arial Black which is like arial but bolded. Also i tried customizing the terminal like TechHut which included installing powerline fonts as one of the dependencies and it did not work. I think fonts are not installing correctly on my pc i dont know why.

@ledeni @scottytrees mscore stands for :slight_smile:

1 Like

I recently had to do this and this is what worked for me.
If you have access to a Windows machine, go to C:\Windows\fonts directory copy the .ttf files of what you need (I just grabbed all of the .ttf files) and put them in a temporary directory on that machine to zip into one file. Find some way to get that zipped file into a temporary directory on your Fedora machine. Once they are in that temp directory in Fedora, unzip them. Either using your File Manager with hidden files in view mode (ctrl-h keyboard shortcut) or from command line (ls -la) look to see if there is a .fonts directory in your home directory. If not, create it (mkdir .font). For each font, create a subdirectory for it (Arial = ‘a’ directory, Times New Roman = ‘t’ directory, etc.) then move those uncompressed .ttf files into those subdirectories.
I initially tried to use the Font Management tool in KDE but for some reason it didn’t work for me. If you are using Gnome, I have actually had success with the Font Management tool in to install fonts.


You may not find RPMs containing WebCore Fonts in fedora repositories. You can either compile them from Source or download RPMs from third-party repositories meant for CentOS. Fortunately RPMs for CentOS are mostly compatible with Fedora.
I see dated versions all over the internet. Somehow my personal repo holds:


You can grab them from:
Download those into a folder. Change to that folder on your terminal. Then do:

sudo dnf install ./webcore-fonts*

You could track the .ttf files for Arial, Times Roman etc. from Font sites and place those files in $HOME/.local/share/fonts/ where $HOME is your home folder