Headphones muted when launching an application

Hello, I will try to express the problem as best as I can because it’s pretty weird and I can’t understand it.
So I use both speakers and headphones on my desktop. I have set auto-mute ON in alsamixer.
Everything was working fine but now when I use headphones and I launch some applications, the master sound is set to 0. It happens when I launch Terminal and VS Code, and I haven’t found other app that provokes it.

I did reset my Fedora recently, I had this bug before and even with a fresh reset it still happens.
So my Fedora is almost “vanilla”, I haven’t touch neither installed anything to affect audios.

There have been several audio bugs fixed by the regular updates. Have you updated to the latest available packages to see if your problem is solved? From a terminal window the command sudo dnf upgrade -y should handle that.

Thank you for your answer but I didn’t fix it.
Also I fixed it by removing a line in my bashrc :

alsactl --file ~/.config/asound.state restore

I used this to make sure I had the good alsamixer configuration but I guess I will find another way

I must say audio on Linux is a real pain in the ass

1 Like