F29: Sound turning on "magically"

One of my favorite things about Fedora? Gnome? is that it remembers the status of the sound across reboots and devices. I normally keep sound muted without headphones except once in a while. Up until a week or two ago, my sound status would be remembered between headphones connected and not and between being put to sleep and waking up. Now, the sound turns back on semi-randomly. I think it may be from disconnecting headphones or waking from sleep but it also seems to happen some other times as well.

Is this a bug that should be reported? Did some config change that changed this behavior? Something else? I have no idea how to begin to troubleshoot it and would love any help with that.

1 Like

Welcome to the community…

It’s weird, your comment don’t help us to much to help you to find out what is the problem?, we don’t know is alsa or pulse audio problem, but I point out with these pages to beginning the journey:


Relevant packages: kernel, alsa-lib, alsa-plugins-pulseaudio
Permissions on device files are managed by HAL
        See what ACLs are set with getfacl /dev/snd/pcmC0D0c
        Users with active sessions should have write privilege
Pulseaudio backend is in package alsa-plugins-pulseaudio
Volume settings are adjusted with alsamixer -c 0
You can play sound with /usr/bin/aplay /usr/share/sounds/alsa/Rear_Right.wav


Relevant packages: pulseaudio
Starts with the session
   Check if it runs with ps aux | grep pulseaudio
   To view log for the current boot use the -b option :
   $ journalctl -b | grep pulseaudio to see if it had any problems
Run verbose pulseaudio on foreground to see detailed messages
Kill running pulseaudio pulseaudio -k or pkill -KILL pulseaudio
Run pulseaudio -vvv
You can play sound with paplay /usr/share/sounds/alsa/Rear_Right.wav


I’ve got an up to date F30 Gnome here so I can try to reproduce this if you think you have certain scenarios where it seems to occur each time? I did a quick test that passed:

  • Mute sound (no headphones, output is just laptop speakers)
  • close lid to suspend
  • open lid to resume
  • Check to see if sound is still muted: YES.

I expect to do a reboot later today after updating, so I’ll also check in that case.

@hhlp : In general, what I’ve learned from the super experienced folks on the IRC is that it is best to ask for the information that you need to help diagnose the issue. If the user isn’t too sure on how to get it, then we also provide step by step instructions on how to do so. That way, the troubleshooting process keeps moving along in a positive direction.

Since we’ve begun moving to quick-docs: any idea if these wiiki pages are up to date/correct?

@FranciscoD my update answer your question…

1 Like

Thanks. I’d expect the results of all those tests to be satisfactory. PA is running fine. We’re trying to see where the state of the device (muted/unmuted) is being reset.

Hi. I’ve been experiencing this on F30 as well. In my case, I have both speakers and headphones plugged all the time. I usually prefer to use headphones, so speakers are turned off by default. Problem is that when both jacks are plugged in, alsamixer by default mutes headphones. I can manually override this by running “alsamixer -c 0”, unmuting headphones and turning its volume up, but I can’t make this setup stick between reboots, not even with “sudo alsactl store 0”…

UPDATE: I tried adding the lines below to ~/.asoundrc and /etc/asound.conf, but they had no effect:

state.PCH {
	control.10 {
		iface MIXER
		name 'Headphone Playback Volume'
		value.0 64
		value.1 64
		comment {
			access 'read write'
			type INTEGER
			count 2
			range '0 - 64'
			dbmin -6400
			dbmax 0
			dbvalue.0 0
			dbvalue.1 0
	control.11 {
		iface MIXER
		name 'Headphone Playback Switch'
		value.0 true
		value.1 true
		comment {
			access 'read write'
			type BOOLEAN
			count 2

(I copied these lines from /var/lib/alsa/asound.state after I manually changed mixer settings through “alsamixer -c 0”, not sure if I am doing the right thing here…)

Similar problem here. F30 Workstation. Fresh install, fully updated.
Steps to reproduce:

  • Sound muted
  • Lock the session (i.e. Super + L)
  • The sound icon in the top right is still muted
  • Log in again
  • The icon, after a second or two, is now unmuted

Edit: the issue happens only if I mute the sound using the keyboard keys. If I mute the sound using the sound slider in the top right, the sound stays muted even following the above steps.

1 Like