Having problem with ssd storage (SOLVED)

Hi, I need help. I tried to reinstall the os (I did it by disable the old os in bios and install new one) because I just installed and managed to fuck everything up. Everything I have tried so far is wiping the ssd and create partition (not sure if I did it right), reclaim space, but non of it worked. Is my ssd ruined forever? Here is my lsblk result.


sudo does not work on the live media.

Both of those SSDs are totally blank so you can simply perform the installation on the device of choice and either allow automatic partitioning (default) or create the partitions manually within the installer.

If you want to define the partitions using fdisk before installing that will force you to also define the use of those same partitions manually within the installer. Note also that if you wish to use gpt partition table you probably should use gdisk and not fdisk.

Thanks, but when tried it said I have 0B free space available and 0B free space unavailable but reclaimable

here is what it look like when I tried to reclaim


after I delete all and reclaim space it would give me just 1 MiB

Use ‘su’ followed by ‘gdisk’ and create a new empty gpt partition table on one of those devices then continue with the installation onto that device.

  1. su
  2. gdisk /dev/nvme0n1 then follow the instructions to create a new empty gpt partition table. w will write that entry to the SSD and exit from gdisk.

Somehow there is an ext4 file system that uses the entire device and it must be wiped out before the device can be used for an installation.

To me it appears that the device was formatted with a file system without ever creating a partition table so the entire device is already allocated. (possibly with mkfs.ext4 /dev/nvme0n1 or similar) That is what must be managed so the space is no longer allocated before it may be used.
Without a partition table the installer cannot reclaim anything.

You cannot preserve that file system and also use the space to install an OS.

You also may have difficulty within a gui performing the necessary task where the command line should handle it easily.

what does this means

and yeah, you are right i use mkfs.ext4

reboot completely and start over. That seems a bit odd and would indicate some other problem.

After the reboot only open the terminal and run su followed by fdisk -l so we can see what the system shows. Also run lsblk -f.

Do both of those before using gdisk.

here anything else I should capture?




No, that is adequate.
Please now use gdisk as I noted above and create a new empty gpt partition table on both those devices.

You then should be able to perform the installation on one or both as you choose. (I would suggest using only one)


what did I do wrong

Simply run dnf install gdisk if it is not already installed.
It should be installed but you may need to use /usr/sbin/gdisk to execute it.

Thanks you so much, I can install it now. You are my hero haha. I will be mindful and ask the community before doing anything I dont know now.

2 Likes

glad to assist and hope things go better for you from here on. :+1:

1 Like