Having an odd message using vulkaninfo and running steam through console (game freezing) [Nvidia] [Fedora 40]

Hello people!

This is my first post here. I came to ask for some help, I’ve been hearing a lot of positive and strong reviews about Fedora. I’ve been trying for some time distro-hopping. And I really like the distro so I’m in need of help because I’m going crazy trying to fix the issues I’m having.

The fact is that right now I’m getting some odd messages. And I’ve run to the point that there’s a game in my case Guild Wars 2 that once I get into its launcher freezes the entire screen (the system still works as the sound keeps running).

I’ve done some research to get some help, so I can keep using Fedora 40 KDE Spin. I followed the installation for Nvidia drivers on rpmfusion. Everything seemed to work correctly.

I decided to run steam through the console to catch this message.

DRM kernel driver ‘nvidia-drm’ in use. NVK requires nouveau.

I also tried to the command vulkaninfo | head. And got this rare message at the very start, next to the same message I wrote before.

ERROR: […/src/nouveau/vulkan/nvk_physical_device.c:935] Code 0 : VK_ERROR_INCOMPATIBLE_DRIVER

I read somewhere that Fedora 40 has NVK enabled by default. I don’t know if this is truth or not, but it seems like somehow it’s interfering every time I run into some applications and creating an incompatibiliy with the Nvidia privative driver.

These issue happens both on Wayland and X11, but X11 gives me more chance to react when the screen is frozen.

I tried this on Arch Linux Plasma 6 too. The only difference I could catch is that I don’t seem to have that interference with NVK.

I’m a bit lost here since I’m relatively new to Fedora. Anyone has a possible way to know what could I do?

I hope I can stay. I’m loving Fedora so far, but I don’t yield easily, so here I am trying to work to fix this challenge!

My card, NVIDIA GTX 1060.

Edit: I didn’t experience the freezing issue on Fedora 39, if that can help somehow.

Edit 2: Well I discovered something quite interesting. When I run the game, the launcher itself does not render correctly, however I’m able to run it (since the data was already saved) so it reacts to keyboard input. Only the screen seems to be frozen until I enter the game.