Graphic(mesa) & Audio issues using Fedora 40 with VMWare workstation pro

Hi All,
I’m working on a windows 11 machine and use VMWare workstation pro 17.5.1 to run a VM for Fedora.
I recently updated from Fedora 39 to Fedora 40 on my VM but here’s the issues I’m facing.

  1. Fedora 40 ISO cannot be installed in VMWare. I can only update my VM from Fedora 39.
  2. Mesa is causing the VM to break when the “3d acceleration” option is set on VMWare. Refer to: https://gitlab.freedesktop.org/mesa/mesa/-/issues/10472
    I can downgrade mesa in Fedora 39 but not being able to do the same thing in Fedora 40.
  3. The audio is crackling and when using arrow keys to navigate to the very beginning or the end of a line and if I keep pressing the arrow key, it will make the terminal lag.
    This audio issue can be resolved by:
    dnf swap --allowerasing pipewire-pulseaudio pulseaudio
    dnf swap wireplumber pipewire-media-session
    
    But although this will fix the audio and terminal performance issue, it will leads to issue 4.
    reference: Reddit - Dive into anything
  4. Video lag when playing videos on Firefox.
    Before upgrading to Fedora 40 I noticed that there’s codecs missing so I did:
    dnf group install --allowerasing Multimedia
    But installing the gourp Multimedia will revert back my previous change to the audio and will lead to corruption in audio again.
    Any help or suggestion is welcomed.
2 Likes

add “GSK_RENDERER=gl” into /etc/environment then reboot your system,and you can enable 3d acceleration.

https://bbs.archlinux.org/viewtopic.php?id=294177

Thank you for your suggestion. I’ve set this in my .vmx file as a workaround for this issue:

mks.enableDX12Renderer = "FALSE"
mks.enableGLRenderer = "TRUE"

The issue now I’m facing is that the videos cannot be correctly displayed using pulseaudio and pipewire-media-session

You’re right about Fedora 40 not working in VMware. I just downloaded the ISO and tried both VMWare and VBox. Both get stuck / freeze at GUI.

1 Like

I just tested latest fedora 40 image on VMware workstation and didint get any issues no freezing no GUI issues got the image from fedora website.

Mesa 3D issues has been fixed on mesa 24.0.5 if I remember that correct and I was running 3D acceleration enabled, but not on windows machine so this might be Windows as host related issue

Can you install and run fedora 40 if you disable 3D acceleration from VMware?

I was only able to upgrade to Fedora 40 from Fedora 39 with mesa packages excluded.
I tried to install Fedora 40 from the ISO with 3D acceleration option disabled on VMWare but the installer window never pop out.
I was able to do a clean installation with VirtualBox but VirtualBox have graphical performace issues and I cannot bear with the lag of the GUI.
The 3D acceleration issue still persists on mesa 24.0.5 on windows host machnie.

I had same that the pop-up never came I just clicked again installer and then it give error something like already running and clicked ok and the anaconda came and installed no issues

I also met the anaconda thing but the window just won’t come out for me for a long time.
Also the audio was fine on VirtualBox only when I boot with the ISO, after installation finished and I get into the system, the audio was broken.
For now, I have a VM instance with Fedroa 40 upgraded from 39, and I fixed the auido issue partially… Which finally leads to video decode issue now for me.

Okey I will get back to home on trip tomorrow and get access on Windows machine I will run some test and see if I get same or similar issues

1 Like

Disabling 3D Accelaration worked. I was able to install Fedora 40.
Enabling 3D Accelaration after the installation has same problems. I can’t even get to the login screen.

The issue is same on new Ubuntu LTS 24.04. I just installed it and it froze the VMware Workstation screen. [Someone had same problem in beta]

Similar issues with VMWare Fusion. Upgrade to F40 went fine, but having issues with audio and video playback (both with and without “3D acceleration” option active).

i would need to ask details on host machine’s that are facing issues since i can not recreate these on my Windows Laptop using intel UHD/Nvidia RTX 3050 TI i can see only small graphical artifacts/boxes on installer, but nothing else that prevents me to install from ISO in Windows host using Latest Fedora 40

EDIT: all browsers are laggy and no sound or laggy sound on VMware installation that seems to be more on VMware issues on Firefox it is even more worst than on chrome

EDIT 2: Browsers with hardware acceleration enabled are even more terrible on VMware installtion and causes system to lag and freeze disable this only laggs browser stream content and browser it self so issues are related VMware and Browsers

1 Like

I have also encountered the same problem and hope to receive a quick fix and resolution

I’ve been able to get by this by disabling 3D in the VM’s settings before booting the F40 Live media. After installation, reboot from the virtual disk and update the software. Make sure Mesa 24.0.5 or later gets installed. You should then be able to turn 3D acceleration back on in the VMs settings.

If things still don’t work, then add the GSK_RENDERER=gl to /etc/environment to force GTK4 to use the old gl rendere instead of the new ngl renders.