Fedora 40 performance issue and lags on virtual machine (VMware Workstation Pro)

Hey there, I’m experiencing performance issues and lags/choppiness with the overall UX, which is making it difficult for me to cope. The issue worsens when:

Opening new windows
Browsing Firefox (such as opening videos on YouTube or scrolling through pages)
I have allocated a total of 4GB of RAM and 4 processor cores, yet the issue persists. The 3D hardware accelerator option has also been enabled, but the issue remains. I have tried following the instructions in this post: Graphic(mesa) & Audio issues using Fedora 40 with VMware Workstation Pro - Fedora Discussion and the issue still exists. At this point, I have given up and want to install other distros until I can find a solution to this problem.

My specs:
All of the hardware below is based on Laptop (mobile) hardware
Host OS - Windows 11 Pro
CPU - i7-13700HX (mobile)
GPU - RTX4070 (mobile)
RAM total - 16gb

How much memory did you allocated to 3D? If you allocated only 4GB ram total that is not enough for 3D and default 3d memory is for 8Gb if not changed and then it will eat all RAm to 3D acceleration

Initially, I let it set to 8GB automatically, but then I changed it to 2GB and 4GB. Oh, I forgot to mention I’m using a laptop, so these hardware are the “mobile” versions.

I would recommend bios virtualization settings first and then disable 3D acceleration to see if it works better if it does then you can keep it or need to pump more memory to VM and 3D acceleration

I usually allocate 768MB of video RAM and 4-8GB of total RAM and have no problems with UX usage.

What are you running as a guest?

Also, which GPU drivers are you using on the host?

1 Like

My main OS is Windows 11 Pro and inside the VMware virtual machines I’ve installed Fedora 40 the latest version.

Oh, in that case, I have you tried using X11 in the VM instead of Wayland?

1 Like