GNOME 40 Trackpad gestures in macOS VirtualBox host

I’m using Fedora 34 with GNOME 40 from a macOS host on VirtualBox. I’m having trouble getting the trackpad gestures in GNOME 40 to work. Instead, when I make those gestures, they are applying to my host machine, rather than the guest. Is there some setting that I may have mis-configured? Thanks for the help.

You probably have to make certain the focus is on that window by clicking on it with the mouse (or the track pad button). You also need to be sure that the VM has access to the track pad properly.

Thank you. Ensuring focus was the first thing I tried; I also tried using the keyboard/mouse capture function with the host key, but to no avail. Is it possible that the Guest Additions drivers don’t enable the trackpad gesture functions? I haven’t found any other configuration settings to adjust. Or is it possible that Guest Additions is treating my trackpad as if it were a mouse?

Can’t answer. I don’t use VB on a laptop with a trackpad so no experience there. I was guessing related to use of a mouse with VMs.

1 Like

You are on Wayland? Are you using full-screen in Virtual Box ?

Yes, Wayland. No to full screen, but I will see if that makes a difference.

EDIT: I can confirm that there is no change in behavior whether the VM is running full screen or not.