Getting Spammed with Remote Desktop Connection window

I was hoping this would be fixed by Fedora 40 (Gnome 46) but I am still being spammed by the “remote desktop connection” window that won’t go away when you click cancel. If there a fix for this or is there one coming? The only solution I’ve found for now is this appears to be a Wayland bug and using X11 instead solves the problem.

I don’t think it has anything to do with wayland vs x11. For instance, I use wayland and never get the issue.

1 Like

Try

gsettings set org.gnome.mutter.wayland xwayland-disable-extension  '["Xtest"]'

the relogin. It disabels the X11 Xtest extension in Xwayland, which is plumbed to the remote desktop portal for backward compatibility reasons.

2 Likes