Gnome; Remote Desktop prompt appears when changing workspace

Hi
I’m using gnome on wayland.
When I use my touchpad to change my workspace this window appears:
image
Its a bit annoying. Is there a way to disable it?

Added remote-desktop

turn off remote desktop

What applications do you have open in the workspace that you’re switching from and switching to? For example the VMware Horizon client tries to do funky stuff with your mouse and keyboard that Wayland doesn’t allow by default. There’s some sort of weird interaction there that seems to happen when switching workspaces that makes this thing pop up for me all the time.

@ledeni I have it already disabled

@mattipulkkinen It doesn’t matter. e.g. for now I have only my brave browser in my workspace, but if I close it, this window will appear anyway.

That dialog disappears if you remove the gnome portal: