Generating /run/initramfs/rdsosreport.txt

How to solve this issue?

It looks like there is a device referenced by your boot image or kernel options that doesn’t exist.

The UUID is listed at the top of the page.

I would start by using blkid, lsblk or similar to see if that UUID exists or not.

If you made partition changes or BIOS updates sometimes UUIDs will change.

1 Like

Not fixed yet.

It is unlikely it will fix itself. Have you tried checking what I recommended above?

yeah, checked.

Actually, I faced this type of issue in all Linux distros. Last 10 days I tried 3 Linux distros. The error is almost the same. I’ve no idea what’s wrong with my machine. Some of my friends also facing the same issue.

Can you share the output here so we can see what it going on?

1 Like

So that UUID still exists.

I wonder if your boot image is missing something it needs to see the disks?

Did this happen immediately after installing?

This type of thing starts while I’m using ubuntu 22.04

To solve this issue I Run fsck, and flag -v to fix the problem. But nothing. There is another issue like

Then I thought it was a drive issue. so I clean the SSD and reinstalled ubuntu 22.04. But still the same. I try with also new SSD. Still same. After that tried Debian. The same type of issue here. Finnay I shift in Fedora. Here are also some issues like this.

Yeah, after installation, reboot then power off and turn on. This thing happens.

You seem to be having different issues in multiple distros.

Have you tried doing a full memory test on your machine to see if you have an issue with RAM?

1 Like

Yeah, already checked the ram. No issue with the ram.

What I am seeing from most of your screenshots is different issues that all relate to disk access. If you already tried removing the physical disk and replacing it with a different one, my next guess would be that either there is something wrong with your disk controller or the drivers that support it.

Can you boot off something with inxi and run inxi -Fxxxz so we can see what hardware you have.

Please, check.

I don’t see anything interesting there. It looks like a straightforward Intel system to me. It is likely that Fedora(and other distros) would work without issue there.

Are you installing to the internal drive or the external drive?

Internal SSD

It looks like a failing drive to me, if you have already tried swapping it out with the same result, perhaps it is internal damage to the cable or connector?

1 Like