Swap partition fails to mount after 1min and 30s... on each boot

Hello everyone! On two different machines, I’ve had the same issue with my swap partition. When installing another operating system, even on a different drive than my Fedora install, the swap partition seems to stop working. Fedora then proceeds to take its sweet time to try and mount the non-existent UUID during boot, but eventually fails. It seems that many different operating systems cause this issue, including Debian 11, Ubuntu (mini.iso), and Windows 10 LTSC, but I’d reckon this happens with others as well.

I’ve seen a few forum posts online where others have tried to fix it, but most of them started using a swap file. Does anyone know what could cause this? Linked below is a full hw-probe of my laptop. I also included the boot.log seperately on hastebin for your troubleshooting pleasure. Many thanks!


I guess your other installed OS changes the UUID of your swap partition.

blkid and a look in the /etc/fstab may show the differences.

Additionally each kernel install will include the swap’s UUID in it’s initramfs.

adjust the UUID in the /etc/fstab and run:

sudo dracut -f /boot/initramfs-$(uname -r).img $(uname -r)

should fix your boot delay

take also a look in your /etc/default/grub
=> resume=… ?

can’t check cause I have not resume statement there

1 Like

Hi sixpack, thanks for your ideas! I tried these solutions and, in particular, regenerated the fstab several times in hopes that something would change. Sadly, it seems that neither of these worked, though there was a resume=some_uuid that I was able to delete. Do you happen to have any other solutions?


Hi, in you login session, if you already add the correct swap UUID to your fstab, when you run swapon -a, from lsblk could you see the item [SWAP] presented? You could also check with free -h after running swapon -a to check.

1 Like

It seems that the UUID was hardcoded in the fstab. I thought I checked this, but I guess not. Your answer led me to see this - many thanks! :slight_smile: