I am unable to bootup Fedora 38 “/dev/disk/by-uuid/ *** does not exist”

Hi, I cloned my old HDD where I had installed Fedora along to Win 11 to a new SSD, now the grub opens but I only can access to Windows not to Fedora:


I tried to boot to a live image and use chroot to recover the access but I had no success. Please help me solve it, I don´t want to format the partition to reinstall and lose the personalization profile I had.
Pdt: My level using Linux is dummie

I wonder – do you by any chance have both disk units attached to your computer? If so, you will get duplicated UUID values, and that confuses Fedora.

Hello @carlsbarg66 ,
I think you will have to change the UUID the boot is referring to in Grub, every device has a uniqe UUID, otherwise it wouldn’t be a Universal Uniqe ID.

1 Like

No, I don’t. The HDD was disabled after the cloning.

You don’t need to erase the UUID from the screenshot, it’s not private.

Run the LiveCD, mount the new drive and run lsblk -o +UUID to see the UUIDs of the partitions. Compare it with the UUID the boot process is looking for. Also compare with the UUIDs on the old drive. If they are not the same, it wasn’t cloned properly (i.e. it didn’t make a 1:1 copy, but instead only copied data, probably, but created the partitions from scratch).

Even if you decided to reinstall Fedora, you can simply copy over your home directory (including dot files) from the old drive and you won’t lose anything.

1 Like

Actually I took the screenshot from another forum. Here is the mine:

Unfortunately I checked the UUID using disks with the liveUSB and what I don’t understand is that the root is installed in the same UUID that the Warning says does not exist.

So I’m not being able to access yet :c

Is grub not supposed to be pointing at the Ext4 partition, in this case?

Not exatly.

/boot/efi/EFI/fedora/grub.cfg points to the /boot file system and /boot/grub2/grub.cfgpoints to the root file system.

Once the root files system has been located, the file /etc/fstab then refers to all the other mounted file systems.

To the OP: We have to look at all file systems, thus at the output of lsblk -fp.

1 Like

Actually any of the solutions was not successful, so I had to reinstall. I tried to recover my home directory by using snapshop from timeshift but It did not work.

Any clue about how I can transfer all the files (including those dot files)?. I copied and paste all files in the home folder but when I call an app from the terminal it is not installled.

Copy and paste is often not an efficient tool when there are hidden files and directories involved. A better choice may be to use rsync instead.
Something like rsync -av /path/to/original/home/dir/ /path/to/new/home/dir/ would work very nicely and would also copy all the hidden (dot) files and directories.

I join this discussion because I’m facing the same error message.

Main differences:

  • I’m running Fedora 39

  • I haven’t changed anything on my system. I’ve started my laptop today and after a few minutes the same error message appeared:

Warning: /dev/disk/... does not exist

What I’ve tried so far:

  • started Fedora 39 XFCE from an USB stick.

  • in Gparted the one and only disk is the USB drive

  • when I’m trying to install Fedora the only available drive during the install process is the USB drive

  • lsblk -o +UUID provides the following result:

NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINTS         UUID
loop0         7:0    0  1.5G  1 loop                     
loop1         7:1    0    6G  1 loop                     adfa4094-4283-474e-91ad-331d4ead9ca3
├─live-rw   253:0    0    6G  0 dm   /                   adfa4094-4283-474e-91ad-331d4ead9ca3
└─live-base 253:1    0    6G  1 dm                       adfa4094-4283-474e-91ad-331d4ead9ca3
loop2         7:2    0   32G  0 loop                     
└─live-rw   253:0    0    6G  0 dm   /                   adfa4094-4283-474e-91ad-331d4ead9ca3
sda           8:0    1 29.3G  0 disk                     2023-11-01-01-22-57-00
├─sda1        8:1    1  1.6G  0 part /run/initramfs/live 2023-11-01-01-22-57-00
├─sda2        8:2    1 11.6M  0 part                     870D-0C07
└─sda3        8:3    1  300K  0 part                     
zram0       252:0    0    8G  0 disk [SWAP]              

The installed SSD should be around 2TB. But I don’t see such a size in the list above.

Do you have any advice how I could at least rescue my data or has the SSD died?

Please start your own thread. This appears that your already installed drive may have failed and is deserving of attention on its own.
The information you posted is good and probably should be repeated in the new thread.

Thanks for your advice.

Started a new thread here.