Fx File Picker no longer shows Dolphin, requires removal of Nautilus to work

Don’t really understand what is going on here. I just noticed it was no longer working and believe it happened when I upgraded to F40, but not sure. In any event, I have a clean install in a VM and it isn’t working there either. What am I missing. I’ve followed the instructions here:


which ones? All three that are posted in the solution?

Did you see Make Firefox use Dolphin file dialog - #7 by player_one - Help - KDE Discuss?

Yes and yes. Do you have it working? This has been working fine for me for years and now all of a sudden it isn’t, so I’m to understand if I have missed something before I open a bug.

Ah, a bit more context… when I download a file, and have “always ask where you save files” checked in settings, the Dolphin file manager is correctly displayed. However, if I display the downloads “ctrl-shift-y” the library is shown using Nautilus and then if I select a file in the downloads library to show the location on my system, it also shows Nautilus. I’m guessing, this is a bug. I’ve never really noticed before because I typically don’t display the downloads library - however now that I have, I find it isn’t correct. Can anybody reproduce this? As I mentioned, it is also reproducible on a clean VM install.

It’s definitely an issue and has been reproduced by others: Make Firefox use Dolphin file dialog - Help - KDE Discuss

The workaround for now is to dnf5 remove nautilus