Full-text search not working after update to F38

Hello everyone!

Could you please help me figure out why I lost the possibility to perform a full-text search in files from the Files app after upgrading from Fedora 37 to Fedora 38?

I know that this could be related to tracker daemons, but I cannot understand why they stopped working even though I did not change anything at all.

Is it similar to Full text search seems to miss results on a fresh install


1 Like

Yep, you are right, but as I can see, there is still no solution to the problem. “tracker3 daemon -w” gives me information about skipped nie:plainTextContent properties, and “tracker3 daemon -f” gives no errors.

What caused the problem?

I have tried to reset ‘gsettings set org.freedesktop.Tracker3.Miner.Files’ to an empty value.
Then, I reset the index using the following commands:
tracker3 reset -sr
'tracker3 reset -f ~
Unfortunately, it didn’t help even though it did reset the index.
The issue remains the same.

UPDATE. After some updates Tracker had started to work again.
I have no idea what the issue was.