[fresh install] Audio issues after updating; Timeshift question

Hi there!

I installed Fedora 35 a few days ago along Manjaro KDE and Windows 10.
As Manjaro decided to behave stupid again, I wiped it and did a clean install of Fedora in that space.

After clean install and on live usb audio works flawlessly.
But after doing latest updates (which include audio related stuff as far as i can tell) audio devices can´t be toggled and sound comes always out of the wrong device.

So I reinstalled Fedora again and for now it all works but I guess just not doing updates is not the recommended way.

I am willing to give feedback if there is interest in. I´m thinking of doing so via the usb live system so I don´t have to deal with the issue on my installed system.

Just tell me, what you need me to do. I can follow your instructions, but though I´m not totally new to Linux I´m mainly a Windows user (due to online gaming sadly).

Related to this I would appreciate any advice/links on how to use Timeshift on Fedora (have it installed, but can not pick any disk space within it) or maybe a better solution as Fedora uses btrfs by default and I am not sure if that was the right decision for me and how to backup/restore system with this.

Welcome to :fedora:

Don’t use this as it is a public forum and all age people see here. And you should not use this for any distro as the maintainers are unpaid mostly and providing a stable os without any bad practices. All member of any distro work hard to provide us service in a volunteer unpaid way.

For timeshift you can install it with

sudo dnf install timeshift

Now for update and audio stuff
There is no such perfect way to install update you can use any of those from commend line with dnf or from software center gui way do it.
Now for audio if after reboot your audio breaks. We can try to solve that particular issue.
For that we need some info
Provide inxi -Fzx
Fedora switch to pipeware wireplumber for audio and stuff so initially you can try to see if those services are running.
systemctl --user status wireplumber.service
Edit: we have pre build a topic about that same issue for look up.

I agree and I know that. Was not meant to offend anyone nor Manjaro. Just a simple conclusion of how that OS behaved again and again in a randomized way sadly.

Timeshift is installed but it can´t see any disk space which is not understandable for me as on other distros I tested this was not an issue and I was able to select the backup path out of the box (a usb hard disk).

Great. I already looked into the topic here on the forum that is about known issue for sound and both workarounds seem not to be aplicable to my case.

inxi -Fzx on fresh installed local system with no updates so far:

  Kernel: 5.14.10-300.fc35.x86_64 x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 Desktop: GNOME 41.0 Distro: Fedora release 35 (Thirty Five)
  Type: Desktop Mobo: Gigabyte model: AX370-Gaming K3
    serial: <superuser required> UEFI: American Megatrends v: F50d
    date: 07/02/2020
  Info: 12-core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2
    rev: 0 cache: L1: 768 KiB L2: 6 MiB L3: 64 MiB
  Speed (MHz): avg: 2479 high: 3622 min/max: 2200/4672 boost: enabled
    cores: 1: 2197 2: 2206 3: 2206 4: 2057 5: 2054 6: 3594 7: 2052 8: 3622
    9: 2058 10: 3620 11: 2061 12: 2062 13: 2209 14: 2194 15: 2208 16: 2055
    17: 2057 18: 3600 19: 2067 20: 3580 21: 2050 22: 3609 23: 2045 24: 2056
    bogomips: 182425
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Cedar [Radeon HD 5000/6000/7350/8350 Series]
    vendor: PC Partner driver: radeon v: kernel bus-ID: 07:00.0
  Device-2: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: Gigabyte
    driver: nouveau v: kernel bus-ID: 08:00.0
  Device-3: HTC (High Tech ) Vive type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 7-3.1.2:7
  Display: wayland server: X.Org v: with: Xwayland v: 21.1.2
    compositor: gnome-shell driver: gpu: nouveau resolution: 1: 1920x1080~144Hz
    2: 1920x1080~60Hz
  OpenGL: renderer: NV166 v: 4.3 Mesa 21.2.3 direct render: Yes
  Device-1: AMD Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]
    vendor: PC Partner driver: snd_hda_intel v: kernel bus-ID: 07:00.1
  Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 08:00.1
  Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 0a:00.4
  Device-4: SteelSeries ApS H Wireless type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-8.3:6
  Device-5: Texas Instruments PCM2902 Audio Codec type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.2:3
  Device-6: HTC (High Tech ) Vive type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 7-3.1.2:7
  Device-7: HTC (High Tech ) Vive type: USB driver: hid-generic,usbhid
    bus-ID: 7-3.1.5:8
  Device-8: Microsoft Xbox NUI Sensor type: USB driver: snd-usb-audio
    bus-ID: 8-2:2
  Sound Server-1: ALSA v: k5.14.10-300.fc35.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.38 running: yes
  Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Gigabyte
    driver: alx v: kernel port: e000 bus-ID: 05:00.0
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 3-1.3:4
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Report-ID: ID: hci1 rfk-id: 1 state: up address: N/A
  Local Storage: total: 1.83 TiB used: 114.41 GiB (6.1%)
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 953.87 GiB
    temp: 37.9 C
  ID-2: /dev/sda vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB
  ID-3: /dev/sdb vendor: Transcend model: TS240GSSD220S size: 223.57 GiB
  ID-4: /dev/sdc type: USB vendor: JMicron Tech model: Generic
    size: 465.76 GiB
  ID-1: / size: 98.91 GiB used: 7.37 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 153.2 MiB (15.7%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 13.8 MiB (2.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 98.91 GiB used: 7.37 GiB (7.4%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 3 MiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 59.1 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: nouveau temp: 40.0 C fan: 683 device: radeon temp: 40.5 C
  Processes: 464 Uptime: 3h 49m Memory: 31.27 GiB used: 6.45 GiB (20.6%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: 13
  note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.13

Up and running (again - on not updated system)

Somehow you have managed to get the number 12 entangled throughout the posted output of inxi above. I have only seen this once before and do not remember how it was fixed, but this should never happen. Possibly as a symptom of the terminal emulator you are using and of the screen from which you are copy/pasting output.

Do the 12s appear on the screen before you copy the text or only in what is pasted here?

I cannot speak to the question about timeshift nor audio but this is at best distracting when trying to make sense of what you posted.

1 Like

Ah thx! Did not recognise this. I ran the command again and now the output is in correct format. I edited my posting.

Edit: Seems like this has to do because I had inxi not installed and used the option to automatically install it and run the command afterwards.

$ inxi -Fzx
bash: inxi: command not found...
Install package 'inxi' to provide command 'inxi'? [N/y] y

which then resulted in

* Testing changes... 
 * Installing packages... 
  12Kernel 5.14.10-300.fc35.x86_64 x86_64 12bits 64 12compiler gcc 12v 2.37-10.fc35 12Desktop GNOME 41.0
    12Distro Fedora release 35 (Thirty Five)


So. Timeshift installed. Snapshot created and updated the system. Back to main topic.

systemctl --user status wireplumber.service now gives:

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2022-03-23 23:34:44 CET; 3min 27s ago
   Main PID: 2277 (wireplumber)
      Tasks: 4 (limit: 38349)
     Memory: 7.8M
        CPU: 467ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─2277 /usr/bin/wireplumber

Mär 23 23:34:44 fedora systemd[1892]: Started Multimedia Service Session Manager.
Mär 23 23:34:44 fedora wireplumber[2277]: Failed to set scheduler settings: Die Operation ist nicht erlaubt
Mär 23 23:34:45 fedora wireplumber[2277]: <WpNode:0x559890c0af60> Object activation aborted: PipeWire proxy destroyed

And inxi -Fzx seems to give exact same output as pre update. At least in the audio section.

Going into system settings and trying different audio outputs seems to do not have any impact at all as none of my outputs gets sound as far as I can tell. In previous installation I had sound from the terminal app coming out of one output at least. Now I think there is another device selected from which I do not get output due to not having audio hardware installed on all devices.

After looking up on the net, it seems to me there might be an issue with wireplumber

If I knew how to check, which packages where updated from which to which version I would try to manually downgrade some of them. But I can not find any log/protocol of what the software gui did and sudo dnf history shows only the stuff I did manually.

please link the article direct and not thru Quant. Brazil and other countries are without that service.

If you have sound then it shoud be running no need to check😀

This is just to check your system config and kernel and some other stuff it should be same maybe the kernel v changed.

No. I updated the system and after that was my last posting because atm the problem exists as described under systemctl output.

I found several similar issues but looking closer they seem to have different errors though related to Fedor update.

This one seems to be very similar (regards error output) though and also very recent, too:

Is this the wrong place to ask?

About what…?!
We try to solve issue you can also try to solve others issues.

About that sound issue. Because for me it looks like the problem seems to be related to pipewire/wireplumber?! And therefore I ask if this here is the right place to ask or if I should ask somewhere else for example on the mentioned packages support platforms.

I do not understand what you mean.
For me it looked like you understood, that my problem is solved which is not. So no need to feel offended or similar (sorry if that term is not the best - I´m no native english speaking person)

I just seen a YT video yesterday where someone else has had sound issues on Fedora 35 but also on Garuda which uses pipewire, too. So that enforces my question if this the right place to ask for.

I installed “EasyEffects” with gnome-software and it has a test signal built in. If I overwrite the used output device it does work!

Atm the default audio output the system uses can not be changed by gnome-settings. Changing output device does not work. Closing gnome-settings and re-opening it proves this. Setting does not get applied.

Sure it is for everything releted to fedora centos and rhel base systems.
You can ask

It means it is a community where we help each other like if you know something you can help others and others all help you for your issues.

I downgraded wireplumber and this solves my issue.

And additionally I locked updates to it with dnf version lock:

About timeshift not showing any disk: It was an issue in the previous version of timeshift but now it is fixed (the package got updated). You may try installing it.

1 Like

That´s right. I solved this issue already. Thx =)

Yeah… just upgraded to Fedora 36. Prior to this I had to upgrade wireplumber to 0.4.10. No sound after that still like with 0.4.9.

So I thought maybe F36 with wp 0.4.10 will work. At first it was a hassle really to get the upgrade even installed (different topic) but after that: nope - audio does not work. Downgrade to wp 0.4.4 not available with dnf.

Thought I´d reboot into F35. Selected it in Grub. Still booted in F36. Great.
No Timeshift has to do its work. Hopefully that will work. Staying on F35 I guess.

Timeshift restore finished. F35 back on track. Can not login anymore.
Guess I´m done with Linux. Sad.