No sound after upgrade install of Fedora 35 (rawhide)

This is not a question per-se but more of a break down of my original issue and the solution.

I recently decided to feel adventurous and jump on the rawhide bandwagon with my laptop running F34 plasma. So as all intrepid explorers do, I promptly performed a dnf system-upgrade and off it went. After approx 1 hr the system had rebooted and installed the necessary.

The system boots and I log in, everything is looking great until I look at the task bar and notice the red strike through the audio indicator. I click this and ‘no sound devices detected’ hmm is this the 5.14 kernel or something else…oh well no time to troubleshoot, put it away.

Today I decide to look a bit deeper, lspci -v showed that the audio device was there and that a module was loaded for it. Typing pactl info showed the pipewire-pulse item was available, but a pactl list sinks short showed nothing. I went into alsamixer which showed that the sound card was literally there as expected, I could modify the volume settings etc.

Long story short, a quick internet search and a trip to the faithful Archwiki pipewire page later the solution was staring me in the face:

a new systemd service has been added which is disabled by default, meaning there is no pipewire-media-session running on system start

Sure enough, systemctl --user status pipewire-media-session showed pipewire-media-session was disabled and not running, so systemctl --user enable pipewire-media-session && systemctl --user start pipewire-media-session being the logical next step that’s what I did and suddenly the audio icon changed back to normal showing the device was there and ready for use.

So the whole point is, for future reference when F35 comes out hopefully this issue will be resolved, but at least you have one possible solution in the meantime.


Fedora 35 is switching to wire plumber.


true. well i probably should have read up on the changes there, but still i feel like the upgrade process should obsolete pipewire-media-session if that’s the proposal


I think that this is covered under the “Scope” section of the change proposal:

Release engineering: A new systemd service will need to be activated in the default install.

Since F35 has just branched, it’s not surprising that this hasn’t landed yet. I would prefer that we get to a place where people aren’t dropping these changes into Rawhide without all the parts lined up, though.

1 Like

There is a good log of accepted changes for Rawhide / Branched Fedora.

It will be great if there is a status field, showing it is “ready to test” or not.

1 Like

After reading that wireplumber was the accepted replacement in the post above by @grumpey and how to switch pipewire-media-session to wireplumber from the change proposal, I installed wireplumber and tested that general audio worked as expected, which it did.


Currently, Fedora 35 Beta uses wireplumber and the system should switch to it automatically when being upgraded. There have been some flaws recently, that wireplumber was not installed by default and pipewire-media-session had to be restarted manually in early upgrades, but this should be gone now.

If problems persist, please report bugs.

1 Like

" sudo dnf swap wireplumber pipewire-media-session "
solved the problem for me.

I work with XFCE


Yes, this worked for me!

It worked for me too.

1 Like

Thank you very much for the quick easy fix. I think that it is just not the real fix of the issue and we will have to revert back to wireplumber when it gets fixed.

I just want to add that this issue is happening in the released version of Fedora 35 and is very inconvenient.


Seconding this - did the F35 release upgrade last night, looked ok but didn’t use it until this morning then found no sound devices listed.
Agree that the switch over ought to work straight away, or they should not bother until it is sorted.

I should add that I run the Cinnamon desktop by choice, as an addition to the originally installed Gnome. I tested in Gnome before finding this post, then after doing the DNF commadn, switched back to my preferred Cinnamon DE with sound now working again.

1 Like

It worked. One additional step i did was reinstalling Pulseaudio

It does work in most cases. I don’t think we’ve identified the situation where it’s not doing the right thing, unfortunately.

The wiki page says to enable and start the wireplumber service
but this didn’t solve it for me, i fixed it by commenting out the
# { path = "/usr/bin/pipewire-media-session" args = "" }
line close to the end of /etc/pipewire/pipewire.conf file and reboot.

I also deleted everything in the ~/.config/pipewire folder, but i think that isn’t neccessary.

If this is a common issue, it would be nice if someone could add it to the “No sound after upgrade” section in the F35 Common Bugs page.


Ah - so different hardware/BIOS or something like that may be the issue?
(and sorry if I sounded off in previous post)

Some basic device details, if it helps at all:

$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xdf240000 irq 137

$ lspci -v | grep -i audio
00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)

Getting SMBIOS data from sysfs.
SMBIOS 3.0.0 present.
Table at 0x8B1A7000.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: American Megatrends Inc.
Version: 3802
Release Date: 03/15/2018

This is just needed if you have made some changes for your selves. A configuration who is different from the default.
The default config files are in /usr/share/pipwire/ this was already communicated in the change-log wiki of F34

Is there a bugzilla about it? I couldn’t find any. It has failed for me on two out of two updgrades. The wireplumber RPM gets installed, but the service is disabled, even though the preset is “enabled”.

no it did not:

afaik the default files changed from /etc/pipewire into /usr/share/pipewire during the cycle of fc34. Which lead to the /etc/ files getting deleted when the change happened:

its not unlikely that people still have the configuration in /etc/, in which case it has to be updated.

I reversed the swap and it seems to be working…
So initially I did …

sudo dnf swap wireplumber pipewire-media-session

as per the suggestion above. This afternoon I tried…

sudo dnf swap pipewire-media-session wireplumber

and rebooted. I still have audio, so I think its working with wireplumber.

[wombat Desktop] $ ps -ale| grep wire
0 S  1000   10233    9894  0  69 -11 - 86774 -      ?        00:00:00 pipewire
0 S  1000   10236    9894  0  80   0 - 136665 -     ?        00:00:00 wireplumber
0 S  1000   10237    9894  0  69 -11 - 62068 -      ?        00:00:00 pipewire-pulse
[wombat Desktop] $