Force Grub to use HDMI instead of DP

Hi there, I am trying to force grub2 to not use my DP 4K monitor on startup on my encrypted Fedora install due to it not being recognized.

Reference: Fedora 38 not working with Gigabyte M28U (4k 144hz/60hz) - #6 by kasazn

I am trying to configure grub with the command


Is this correct as my xrandr output for my 2 displays are XWAYLAND0 and XWAYLAND1 with XWAYLAND1 being my DP 4K 144hz monitor.

From the guides I see only, other people’s xrandr output will show something among the lines of VGA0, VGA1, HDMI, LVDS and etc.

This is so that the LUKS password screen will use my HDMI monitor only. LUKS password screen still works with the 4K monitor but when it comes to the Fedora login screen, my 4K screen does not work anymore.

Maybe can help me on setting up the Fedora password screen (not the LUKS password screen) to force using my HDMI monitor only as well?

1 Like

Interim solution: I changed distro to ArchLinux and now it’s running fine with “sudo pacman -S nvidia”.