Fedora 38 not working with Gigabyte M28U (4k 144hz/60hz)

Hi there.

I’ve been a long time user of Fedora on my laptop.

Now I’m booting it on my main PC.

CPU: Ryzen 9 5900X
GPU: RTX 2080S (RTX 4090 still in RMA)
Monitor Setup: 2x Monitor (1 FHD, 1 4K)
Fedora parition: Encrypted

GPU Driver: Installed officially Fedora supported nVIDIA drivers from rpmfusion.

Fedora 38 runs nicely on grub up until the login screen then my 4K screen will not respond anymore. When I plug in my Dell FHD monitor, everything works fine. I tried using my 4K screen as secondary, doesn’t work although it appears in system’s display setting. Doesn’t work on 144hz/120hz/60hz.

My setup works fine on Windows without any issues.

Anything that can help with my problem here? Also when my RTX 4090 comes back, I plan to use it on my main PC.

EDIT: Further information, if the 4K screen is set to use 1080p & 2048x1152 144hz it works. Weird.

EDIT2: Boot up Ubuntu 22.10 and experience the same issue.

I’ve seen 2 people mentioning issues with Nvidia drivers after updating. ex: Liam: "Upgraded to #Fedora 38 and it no longer boots up.…" - Mastodon

Sounds like a driver reinstall was needed? Not much to go on, but I figured it was worth mentioning.

Is that card capable of 4K? I have not checked. Many that are capable of FHD at 144hz can only do 4K at 30hz. Have you tried 30hz?

What driver version is installed? dnf list installed akmod-nvidia
What have you set the display to within the settings control panel?

Interesting. Behavior is the same in display detection before I install nVidia drivers and also after.

I’ll investigate further once I reach home.

The card is perfectly capable of 4K 144hz. I’m playing games with the exact same setup on Windows.

FYI I am dual booting Windows / Fedora, both on a seperate physical SSD.

I’ll give you the output of the driver version once I reach home.

Output of “dnf list installed akmod-nvidia”:

$ dnf list installed akmod-nvidia
Installed Packages
akmod-nvidia.x86_64                         3:530.41.03-1.fc38                          @rpmfusion-nonfree-nvidia-driver

Interestingly I got curious and went to set it to 1080p 144hz, it works now.

Further info: If it’s on 4K resolution, it’s not working. Connected by DP cable.

Still wish I can run it on 4k 144hz.

Interim solution: I changed distro to ArchLinux and now it’s running fine with “sudo pacman -S nvidia”. Will stay on Arch for now.