Flatpak MS teams proxy issue

Hello everyone,

the com.microsoft.teams flatpak does not seem to respect my system proxy settings.

It seems, the flatpak copied the settings when it was installed, and any change to the system settings (org.gnome.system.proxy) are not reflected in the flatpack application.

I tried to uninstall and reinstall it but I still have the same issue.
I tried the update the gsetting inside the flatpak application but it does not update the related http_proxy environment variable.

$ flatpak run --command=sh com.microsoft.Teams
gsettings set org.gnome.system.proxy mode 'none'

How man is supposed to tweak environment variable with flatpak application ?
in the .desktop file, I did not find anything.

Does anyone can put some light on this ?



You might try setting the all_proxy variable and then launching it from terminal, ie: export all_proxy=socks5h://proxy-host:8080,etc. It could use https_proxy or http_proxy instead, but at least one of those, and most likely all_proxy, should work.

Temporary solution: Assuming you are using this unofficial client from flathub.org, run from terminal as:

http_proxy="$http_proxy" https_proxy="$https_proxy" ftp_proxy="$ftp_proxy" all_proxy="$all_proxy" flatpak run com.github.IsmaelMartinez.teams_for_linux

I tried and this works for firefox and signal app. Try if it works.

Also, do note that the official Teams for Linux has been retired by Microsoft. This app from flathub (assuming you are using this one), is an unofficial electron wrapper around the teams web-app. You might be better off using the official PWA. The official PWA for teams only be installed using chrome and other chromium forks (like Edge and Brave) and not using Firefox. You can find installation instructions here.

1 Like