Flatpak apps crashing after rebasing from Silverblue to Kinoite


Recently I did a rebase from Silverblue to Kinoite. The rebase itself went smoothly and I was greeted with the KDE welcome screen. I am using wayland. Also tried X11, same result.

Many Flatpak apps do continue to work. However, some of them crash either immediately or after showing their GUI for a second or two. Examples: LibreWolf, Lutris and BitWig crash after showing their GUI. MarkText doesn’t even show the GUI. VLC plays audio from video files, but can’t show the GUI and crashes after a few seconds. Steam runs, although didn’t check any games.

My assumption is there’s something wrong with how graphics is set up, or something with the paths and locales. Unfortunately, I am unable to fix the issue. LibreWolf’s issue gets temporarily fixed if I clean up its startup cache, only to crash again the next startup. BitWig stopped crashing by completely uninstalling and clearing all data, and reinstalling it again. But it still crashes occasionally.

The weird thing is that they activate their GUI, and I can interact with it for a second or three before crashing. If it was something wrong with Optimus I assume they wouldn’t show the GUI at all, but maybe I’m wrong.

My ostree layering is so:

● fedora:fedora/38/x86_64/kinoite
                  Version: 38.20230531.1 (2023-05-31T16:11:24Z)
               BaseCommit: [obscured]
             GPGSignature: Valid signature by [obscured]
          LayeredPackages: distrobox gcc kmod-nvidia langpacks-core-mk qjackctl tlp tlp-rdw xorg-x11-drv-nvidia
            LocalPackages: [obscured, not important]

Here is what they show when run from console with -vv (very verbose; the last few lines). As you can see, almost nothing in common between the apps, so can’t pinpoint the exactl issue. It seems like some of them don’t print the actual error which caused them to crash:


F:     /etc/egl/egl_external_platform.d:/usr/lib/x86_64-linux-gnu/GL/egl/egl_external_platform.d:/usr/share/egl/egl_external_platform.d
F: Running '/usr/bin/bwrap --args 42 librewolf'
[ERROR glean_core] Error setting metrics feature config: Json(Error("EOF while parsing a value", line: 1, column: 0))


F: Running '/usr/bin/bwrap --args 45 lutris-wrapper'
2023-06-01 09:47:18,800: Starting Lutris 0.5.13
2023-06-01 09:47:18,805: Using NVIDIA drivers 530.41.03 for x86_64
2023-06-01 09:47:18,805: GPU: NVIDIA GeForce GTX 1650
2023-06-01 09:47:18,806: GPU: [obscured] (i915 drivers)
2023-06-01 09:47:18,806: GPU: [obscured] (nvidia drivers)
2023-06-01 09:47:22,432: Startup complete


F: Running '/usr/bin/bwrap --args 42 vlc'
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)
[000055b8b883c430] main interface error: no suitable interface module
[000055b8b8759710] main libvlc error: interface "globalhotkeys,none" initialization failed
[000055b8b8759710] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000055b8b883c430] skins2 interface error: cannot initialize OSFactory
[000055b8b87f4d70] main playlist: playlist is empty
[000055b8b883c430] [cli] lua interface: Listening on host "*console".
VLC media player 3.0.18 Vetinari
Command Line Interface initialized. Type `help' for help.


F: Running '/usr/bin/bwrap --args 39 marktext'
strict mode: missing type "string" for keyword "pattern" at "#/properties/spellcheckerLanguage" (strictTypes)
[2:0601/095159.887911:ERROR:bus.cc(392)] Failed to connect to the bus: Failed to connect to socket /run/dbus/system_bus_socket: No such file or directory
[46:0601/095159.902000:ERROR:gpu_init.cc(453)] Passthrough is not supported, GL is swiftshader, ANGLE is 
09:52:00.498 › Failed to decrypt secure keys: Error: user interaction failed

Any suggestions to try?

OMG I can’t believe the solution is so simple: enable affected apps to run in the background.

It seems that for some apps KDE background portal are force-closing them, for whatever reason. Until this is fixed the solution is to install Flatseal and enable those apps to run in the background. It is stupid, I know, but it works.

There are other people with this issue too: Reddit - Dive into anything

1 Like