Flameshot v12.1.0 (flatpak) on f37 does not work after updating packages


I use sway and installed Flameshot v12.1.0 via flatpak and it worked in December 2022 and stopped working in January after I updated my packages via rpm-ostree update. Rolling back to pinned version before the update workes just fine. I use also swaywm and Silverblue spin, but I think this is not related to the bug itself.

When I run:

flatpak run --devel --env=XDG_CURRENT_DESKTOP=sway org.flameshot.Flameshot gui

There is no output and it takes a while and nothings happens. When I cancel it and try again it exits sometimes faster but also with no output. I don’t know where to start looking for the cause and also don’t know how to debug it.

It looks like I am not the only one having that issue (see github issue linked below). Looking at that issue it seems that snap flameshot has the same issue. Flameshot doesn’t changed for couple of months so it must be a dependency in the system that causes it.


Not yet known.

Related Issues

Hi Alexei! Did you mean to propose this as a Common Issue? This utility looks like it has some nifty features the built-in screenshot tool lacks, but I’m not sure it fits the criteria for a widespread, significant problem…

Hi Matthew,

then maybe I misunderstood what the “Common Issues” is for. Where would be the right place to open an Issue like that. I mean something in the dependencies break the compatibility to that tool, that worked flawlessly before. What I also have after the update is that sharing of me screen via MS Teams Web on Chrome stopped working. It may be related but I am not sure, I thought maybe it’s pipewire change that causes it but I am lacking the knowledge to debug it.

Sorry if it causes now more work on your site because of the wrong category.

The upstream issue seems the best place to discuss it, in order to figure out which component caused it (and then report it against that).


This was no problem, by the way. It’s better if things come in the right category, of course, but it’s not hard to move them.

1 Like