Add GNOME Screenshot on Fedora OCI

Obviously I want to have Screenshot tool (:p), which isn’t on the base image, so I opened a PR for adding it on Flathub; my question is, if we can open such PRs for Fedora Flatpak OCI, or is something only SB maintainers do?

Creating Fedora Flatpaks is something that any Fedora packager can do. Our goal is that eventually packagers are maintaining the Flatpaks of their own packaged applications .

https://docs.fedoraproject.org/en-US/flatpak/tutorial/

Starts off with how to create a Fedora Flatpak locally - which can be done without any special privileges. Then you need packager privileges to get the Flatpak content imported and start builds. There’s no real procedure for becoming sponsored into the packager group just to create Flatpaks, yet, though if anybody is interested, we can definitely figure something out!

2 Likes

I wish the procedure was as simple as Flathub, but anyway, I will try that! Thanks!

It’s a good idea, anyway the logic of not including gnome-screenshot is that gnome-shell offers the basic functionality to take screenshots via keyboard shortcuts.

it misses the “delay” which very essential …except if there is some s/c for it i dont know :confused:

I am trying to work on some documentation and I found that I needed a better screenshot tool. I found Shutter in the Gnome Software store, but it is an RPM install. It would be nice if it were available as a Flatpak package. The only problem I found with Shutter is that it does not work with Wayland. I had to login to the Gnome Xorg session to get it working. :frowning: I hope it will get Wayland support soon.

It would also be an option for gnome-screenshot to receive some extra features, such as being able to make small editions (some text, arrows, etc.).

Shutter is unmaintained upstream and not only depends on X11, it also uses deprecated GNOME 2 libraries (via their Perl bindings). Debian had to drop it from its repos for the next stable release. It’s incredibly unlikely it’ll ever be ported to GTK 3 and acquire Wayland and HiDPI support.

3 Likes

best practice here is what Plasma Screenshot tool does; when you take a screenshot, it has an “Open With” option, so you can open the screenshot on a drawing app for example Gimp, oron this new Drawing app that is simpler to use, and edit it

but i think GNOME Screenshot misses a maintainer, b/c it has unresponded PRs; and not much of development either

I just used the Software Manager to install Flameshot without any hitches. However I added Cinnamon DE right away after installing Silverblue

https://paste.fedoraproject.org/paste/i9Bb7V9BvhdOQOf2X06Q0g

I have what I believe to be a CMOS Battery on its death bed issue? My Browsers crash often. And my reboot earlier took most of my earlier software installations out. This Silverblue is very new to me. I did most all of my earlier software installations through Terminal with # rpm-ostree install xxx xxxx Commands and pretty much anything in yum or dnf as well as rpm fusion installed. I should mention too that I on my first fresh boot installed through Terminal cinnamon, alien, yolo, and some other software before the systemctl reboot and all was going pretty much the same as my F30 Workstation except for perpetual Browser Tab Crashes and ultimately rebooting into what was almost like a fresh new Install all that was left was Cinnamon and Etherape on a quick glance. I wish I had saved a System Info shot of that. That is what prompted me to try to do screenshots is my configurations are pushing things and am trying to capture glitches along the way. This is an amazing Project I want to stay close to. Thanks all.

Thanks for mentioning Flameshot, I did not know about it before. I checked it out and it is a very good screenshot app. I think I might switch to using that now. Only downside is that it is a non-Flatpak app from the Fedora repo. I am trying to stay with Flatpak applications on Silverblue as much as I can. Maybe I will learn how to make a Flatpak for this app.

It looks like Flatpak development is well underway on the flathub github for Flameshot app. I guess I will just wait for it to be published soon.

I am still trying to figure out how all this Silverblue works. But I think my installation created a Flatpak of Flameshot and it went somewhere in the rpm-ostree world. I am on my phone right now. I will see if it is available for pulling from any repos when I get back home.

Cheers

When I install a piece of software in Silverblue I use the # rpm-ostree install flameshot Command. It goes through a bunch of contortions pushes and pulls then generates a Flatpak of that RPM ( with alien other packages as well ) and deploys it. I believe a clone goes to a Fedora/Silverblue ( ostree or atomic I am not sure what all ) repository. I think this is what is happening? I just installed a bunch of Git control stuff on my other rig to see if I can manage these in something like Gitkraken or even VSCodium with extensions.

Hi wildegeist. Actually, the rpm-ostree command will install an RPM package of the application. This is what’s known as package layering, and is another way to add software to Silverblue. It creates a new ostree image that is a combination of the base ostree image plus the installed layered RPMs. Installing layered RPM packages requires a reboot before you can launch them.

However, Flatpaks are installed using the flatpak install <flatpak-app-name> command or Gnome Software app and are located outside of the ostree image. Flatpak installs do not need a reboot after installation to be able to use the application.

Speaking from the POV of having experienced it, if you do consecutive rpm-ostree install <software package> without a systemctl reboot in between those successive commands, you will likely end up with a “no default user” system that will prompt you to create a new user at startup. If you want to layer multiple packages and know which ones in particular, you should do rpm-ostree cleanup -m first to get your meta data refreshed on your system. Then just use rpm-ostree install app1 app2 app3 ... appN and it should install all apps/packages and resolve dependencies effectively. Then you would do the usual systemctl reboot to restart into your new ostree.

Flatpaks are not created in that fashion, they are basically containers. Silverblue uses rpm-ostree which is a variant of ostree that allows layering of packages onto the system image. So when you use rpm-ostree install someapp this is layered onto the core image provided by the repo. That process of layering can, and often does, pull in other items to satisfy dependencies. The image you created by layering only exists on your system, the base image it was created from still exists on the repo you pulled it from. If you would like to check out a good explanation and quickstart guide on Silverblue go here https://miabbott.github.io/2019/01/22/silverblue-day-1.html and you will find a very straight forward explanation of Silverblue, with practical examples of what and how.

Has that happened recently still? If so, have you thought about filling a bug report? I’ve done this with no issues, so there’s definitely something up here…

I haven’t tried that recently, so I can’t say whether it is still happening. I don’t have an issue with doing a reboot after changing layering on the ostree, and I prudently make sure the metadata is clean before doing anything to the ostree. Those are habits I decide I would adopt early on after I ran into problems by not doing them.