[fixed] Updating Kinoite broke things, not even a rollback fixes it

Hi,

I recently upgraded my Kinoite system via rpm-ostree and started encountering some strange graphical bugs and a nasty kwin segfault.

I stupidly forgot to do a pin before the upgrade, then I upgraded again hoping that would fix it, and I lost the last release that I had working. However, I do have a much older pin from 3 months ago, but even when I boot into that I encounter the exact same bugs and crashes. So whatever is causing the bugs persists after a rollback.

Kwin Segfault

Kwin segfaults every time I try to maximize a window by dragging it to the top of the screen. This is 100% reproducible for me, and dmesg prints the following:

[ 1058.935511] traps: kwin_wayland[5339] general protection fault ip:7f4a4eee0e37 sp:7ffcfd2af3f0 error:0 in libQt6Quick.so.6.7.1[7f4a4ed61000+44f000]

Visual glitches

https://www.youtube.com/watch?v=wc5OSa4xzJ8

The other problem is a weird visual bug with icons. It’s hard to explain, so I’ve recorded a video of it occurring in the plasma task bar and the system settings app. I’ve seen it happen in the following apps:

  • Plasma task bar
  • KDE settings app
  • KDE welcome window/popup

It’s weird because these issues persist even when I roll back to a much earlier image from 3 months ago which definitely did not have these issues.

Here’s my system information:

Operating System: Fedora Linux 40
KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.1
Kernel Version: 6.9.5-200.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 24 × AMD Ryzen 9 7900 12-Core Processor
Memory: 61.9 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 4090/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: B650M K

EDIT: upon using my eyeballs I can see that it’s not a “segfault” :man_shrugging:

1 Like

I fixed it!

Idk where it came from, but a mysterious icon appeared in my task bar and when I clicked it, it launched a “Plasma Renderer” settings application. The rendering backend option was set to “Software”, so I switched it to Automatic and rebooted and now everything is back to normal.

strange, this is not a fix but a workaround.

I had similar crashes when maximizing a Youtube video playing on Freetube, with no error in the Freetube flatpak log.

Jun 26 00:07:35 PC systemd-coredump[391292]: [🡕] Process 391126 (freetube) of user 1001 dumped core.
                                             
                                             Stack trace of thread 2:
                                             #0  0x00005630a874d5e5 n/a (/app/freetube/freetube + 0x25e45e5)
                                             #1  0x00005630b0234ab9 n/a (/app/freetube/freetube + 0xa0cbab9)
                                             #2  0x00005630b023461e n/a (/app/freetube/freetube + 0xa0cb61e)
                                             #3  0x00005630b0233d14 n/a (/app/freetube/freetube + 0xa0cad14)
                                             #4  0x00005630b0232bd9 n/a (/app/freetube/freetube + 0xa0c9bd9)
                                             #5  0x00005630b02329aa n/a (/app/freetube/freetube + 0xa0c99aa)
                                             #6  0x00005630a8720355 n/a (/app/freetube/freetube + 0x25b7355)
                                             #7  0x00005630a8717bee n/a (/app/freetube/freetube + 0x25aebee)
                                             #8  0x00005630a9146b6f n/a (/app/freetube/freetube + 0x2fddb6f)
                                             #9  0x00005630a915f6d5 n/a (/app/freetube/freetube + 0x2ff66d5)
                                             #10 0x00005630a84ef855 n/a (/app/freetube/freetube + 0x2386855)
                                             #11 0x0000000000000000 n/a (n/a + 0x0)
                                             ELF object binary architecture: AMD x86-64

Forcing it to use X11, i.e. XWayland fixed it.

I am not on NVIDIA though, all intel, perfeclty supported. Also just happened since Plasma 6.1

I was so free and removed the “solution”, as this should not have happened, and I would consider this a workaround. Feel free to revert it though.

searching for kwin crash issues this seems to be a lot of stuff with their new fancy VRR implementations…

yay, crashing features with a minor release…

I reported my issue please report yours too. So it seems to default to software rendering?

Added plasma6

I created a report here

EDIT: btw I should probably add that I don’t remember whether or not I ever set that option to software rendering myself, or if it changed by itself with a recent update. I’ve been running this system for over a year now, so it’s hard to remember everything I’ve tweaked.

1 Like

Added bug-reported

Wouldn’t ostree log <branch> where branch is fedora/XX/x86_64/silverblue
list all the commits in your OSTree repository?

Then deploy a commit by using it’s checksum rpm-ostree deploy <commit-checksum> ?

Then pin the one you want rpm-ostree pin <commit-checksum>

1 Like