Glitches in Fedora Kinoite

After some recent updates in my freshly installed Fedora Kinoite, I noticed that every time I run an app, the display begins making a sort of glitch (I can see the desktop under the app for a little while) and keeps doing this continously. Some apps do it more (example Steam, Chromium) some other less (Firefox) and some never (Dolphin). Can it be related to my graphics card (Nvidia GeForce GT 610 )?
Does anybody have the same problem?

1 Like

Are you using wayland or x11 and are you using opensource driver or nonopen source graphics driver.

I’m using X11 (Wayland freezes on login) and nouveau driver

1 Like

You’ll probably want to give the official NVIDIA driver a try.

I am running Silverblue. How would I check to see if I am using wayland or X11?

In a terminal

On the login screen there’s a cog on the bottom right that allows you to select which session you’re running.

Thanks. Its Wayland. Thats the better one, right?

Hi Gianluca. I too see these same glitches as you describe in Kinoite. For me I see it with dual monitor where the background of the new launched app shows a snapshot of the opposite screen where the same window would be located. Also, I got crashes with the nouveau driver and Wayland. So now I am using the NVidia driver with X11. I still get the opposite screen snapshot background on the new launched window, but it does not persist for very long and then the regular app screen content replaces it and it is fine after that. I think it might be related to either the KWin compositor and/or NVidia driver interaction.

That really depends on your hardware and use case.

I personally prefer Wayland (sway) because it solved some screen tearing issues I had but I also don’t do any screen recording and don’t have nvidia hardware.

I’d suggest reading up on Wayland and X11 and looking at what your hardware and plans are and make sure it fits.

I noticed that the problem seems to be resolved with the xorg update of today.
Now I am testing many applications and none of them seems to cause the same glitches as before.
The problem with Wayland (immediate freeze of the entire session on login) still persist but for now I’ll continue in using x11.

1 Like

@apollo18 I thought this video did a great job of explaining Wayland in a simple, easy-to-understand way.

1 Like

I have to correct my previous reply because, after a few days of work, I noticed that the problem is still there… far less then before but persistent. The video is still flickering quickly and randomly on many apps

Hooray! Latest update to Kinoite is working much better with Plasma on Wayland. I no longer get slow response, freezes, or crashes after I login. There are still some weird visual artifacts and I do not get any launch icons in the main panel. Also, some apps do not work at all like Teams, Zoom, and LBRY. Anyway, it is good progress. Could 2022 be the year of Wayland?

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.15.17-200.fc35.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-4790K CPU @ 4.00GHz
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2


With the recent updates, the problem seems to be definitely solved.
Unfortunately my experience with wayland is still the same because the whole system keeps freezing after login.
These are my specs:

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.15.18-200.fc35.x86_64 (64-bit)
Graphics Platform: X11
Processors: 2 × Intel® Pentium® CPU G3220 @ 3.00GHz
Memory: 7.7 GiB of RAM
Graphics Processor: NVD9


You say the problem is solved, then you say there is a problem that is still the same? Which is it? What was solved? If the original topic of this thread was solved then please mark the appropriate post as the solution. If there is another problem that was not the topic of this thread then please open a new thread.

It makes things easier for everyone to follow and for searchers to find later if only one problem is discussed in each thread.

Sorry for the confusion.
The problem was present only when running xorg and now this has been solved itself with updates.
The problem with wayland is not related with the original post, my mistake.