Firefox crash on start

Firefox keeps crashing on start
It keeps popping up a restart or quit box until it finally offers to start in safe mode
It does start in safe mode
I tried everything
clearing cach and cookies
uninstall - reinstall
install flatpak same thing or wont start
removing .mozilla and mozilla form .cach
new user
anyone know how to fix this?

After uninstalling you should check and see if /etc/firefox remains. If it does then remove it as well before a reinstall.

Have you tried creating a new user and testing if the same thing happens when signed in as that user? If not then it is something about the config for your user. If it does then it is something in the way firefox works for your system and not user config.

Have you made certain the entire system is up to date? sudo dnf upgrade
Have you made certain all traces of the flatpak are removed?
You need to work with one version of firefox, and preferably what is installed by the rpms from fedora instead of bouncing between types and repos just hoping something works. The more off-the-wall stuff you do the more there is to cause problems and the harder it is to track down the actual error.

I have never heard of firefox acting like you describe when it is the version installed with fedora when first installed and routinely updated from the fedora repos.

Have you even looked at the logs to see what might pop out at you?

etc/firefox empty
already tried new user same thing happens
did the upgrade same thing
Yes I made sure all flatpak traces removed
Yes this is the version installed from fedora repos
Also learned that most flatpaks don’t launch
turned off hardware acceleration in firefox same thing
Since this is a new firefox reinstall no extensions and no themes
This happened out of no where used firefox and came back about 3 hours and can’t use firefox
Took laptop apart reinstalled ram and reinstalled ssd
This just doesn’t make sense
Where do I find the logs?

Install again firefox and try to run default profile manager (right mouse button on firefox icon ).

@Igor Bezrodnik tried it no change