Opening link causes “Firefox is already running, but is not responding” with flatpak

Meta point: this feels to me like a packaging bug that belongs in an issue tracker rather than a discussion forum. Where is the right place to file flatpak packaging bugs?

On F40 I have Firefox installed through Fedora’s flatpak (details below). When I click on a link in another app, it always fails with a popup that says:

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

I imagine such a click ends up running something similar to this, which reproduces the same error message:

$ flatpak run org.mozilla.firefox --new-tab https://example.net

Many search engine results explain how to kill a stray process that did not exit cleanly. This is not what’s happening here: Firefox is running perfectly fine within its own windows. But talking to it from the outside fails. Maybe because of isolation provided by Flatpak?

These do sound relevant, as about:supports in Firefox does list “Window Protocol: wayland”:

… but they don’t actually help, this still fails with the same error message:

$ flatpak run --env=MOZ_DBUS_REMOTE=1 org.mozilla.firefox --new-tab https://example.net

Extra info:

$ flatpak info org.mozilla.firefox

Firefox - Web Browser

          ID: org.mozilla.firefox
         Ref: app/org.mozilla.firefox/x86_64/stable
        Arch: x86_64
      Branch: stable
     Version: 125.0.3
     License: GPL-3.0+
      Origin: fedora
  Collection: 
Installation: system
   Installed: 253.2 MB
     Runtime: org.fedoraproject.Platform/x86_64/f40
         Sdk: org.fedoraproject.Sdk/x86_64/f40

      Commit: aee94906526e00fa39e7bd035e1426abf59c2660da2d21032cfb492c3c8c3e0a
     Subject: Export org.mozilla.firefox
        Date: 2024-04-30 09:24:23 +0000
      Alt-id: 92f2292e5d654994902673803a3017324ac635d8880b866655f616fddf395a3a

Removed audio

Confirmation that Flatpak is responsible: installing with RPM instead fixes this problem.

It is always good to tracking Issues alias reporting bugs. Here some information how to proceed and which kind of information is needed:

Following the last link of the Document brings you to bugzilla and shows you which information is needed to report an issue. Remember to check first if the issue is reported and maybe is an regression. If you report newly, please be aware that the problem has to be reproducible to be fixed.

p.s.
Please also complete your tags with your environment/de you are using. See hostnamectl for further information.