Fingerprint reader does not work

Hey, guys

I can’t get the fingerprint reader to work on my laptop running Fedora 39. I have already tried several things that were recommended to me, but I still can’t get it to work.

When I was going to set up the fingerprint reader for the first time it threw messages like this:

  • Fingerprint device disconnected.

  • Failed to request the fingerprint device ElanTech Fingerprint Sensor: Failed to communicate with the fingerprint reader.

Here is what I have done so far:

  1. I checked if the reader was active or not with the following command: systemctl status fprintd.
    It gave me the following:

  1. Then I tried the following to activate it
  • To start it: sudo systemctl start fprintd
  • To start when the laptop boots up: sudo systemctl enable fprintd
    When I placed these commands I got the following results:

    The latter did not work either.

I don’t know why the fingerprint reader is not working, what do you think I can do?

I have a Lenovo IdeaPad 3 15ALC6 laptop.

you have to check the ID and see if there is a driver for it.
Check lsusb output and see if it is for example here:
https://copr.fedorainfracloud.org/coprs/manciukic/libfprint-tod-goodix/
there are other sources and ongoing attempts to make certain hardware works.
It starts with the USB ID and a google search on that…
good luck!

this authselect part may be needed too, it was for me to have it show up in the gnome UI:

From that post :slight_smile: > Configure fingerprint reader

Install the needed packages
sudo dnf install fprintd fprintd-pam

Make sure the service is enabled and running

systemclt status fprintd.service

If it needs to be enabled or started

systemclt enable fprintd.service
systemclt start fprintd.service

Erase any old prints
fprintd-delete $USER

Let’s enroll your new fingerprints
fprintd-enroll

Verify new fingerprints
fprintd-verify

Make sure PAM is authenticated for fingerprints

sudo authselect enable-feature with-fingerprint
sudo authselect apply-changes

Verify it

sudo authselect current

Upon reboot, your fingerprint will allow you login.

I went to the link you provided here, but it is exclusive for Dell laptops, I am not sure if it will work on my Lenovo laptop.

In order to continue, I need you to confirm that the solution you proposed in your first comment will indeed work for me.

Since I don’t want to make changes that may affect the operating system or cause problems later on, I prefer to be cautious.

Once you confirm the viability of the solution, I will proceed to implement it immediately.

I appreciate your understanding and patience in this process.